Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1575043 - BSoD When a huawei phone plugged in
Summary: BSoD When a huawei phone plugged in
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: spice-usbdk-win
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 8.3
Assignee: ybendito
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 15:38 UTC by Sameeh Jubran
Modified: 2020-08-04 04:59 UTC (History)
7 users (show)

Fixed In Version: spice-usbdk-win-1.0-22 spice-client-win-8.3-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-04 04:59:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
UsbDkTrace_blueescreen.etl parsed to text (3.88 KB, text/plain)
2018-05-06 16:40 UTC, Sameeh Jubran
no flags Details

Description Sameeh Jubran 2018-05-04 15:38:06 UTC
Description of problem:

https://github.com/daynix/UsbDk/issues/59

This issue was originally reported here:

The reported post:
A BSoD occurred when I plugged in a huawei phone. It's about an 80 percent probability that happened.
Log attached below.
UsbDkTrace.zip
I traced the code and it seemed that phone was recognized as a hub due to an error when requesting the phone's Device descriptor.
Any help will be greatly appreciated!

Comment 1 Sameeh Jubran 2018-05-06 16:40:39 UTC
Created attachment 1432404 [details]
UsbDkTrace_blueescreen.etl parsed to text

Comment 2 Victor Toso 2018-05-07 17:24:33 UTC
Thanks for filing the bug here too. Added to 4.3.

Comment 3 ybendito 2018-10-11 05:30:37 UTC
There is no simple way to reproduce the problem: it can be reproduced on Windows 7 (on Win10 it does not happen or reproduction rate is very low), for that needed composite USB device that contains at least 2 interfaces when one of them is CD.
Not having such device, I've succeeded to simulate it with spice-gtk pilot supporting cd-sharing (https://gitlab.freedesktop.org/yuri_benditovich/spice-gtk/tree/cd-sharing-as-composite), modified to create composite device with additional interface. When such device shared with guest, crash happens 4/5.
The fix applied   
https://github.com/daynix/UsbDk/commit/960f44ed2c697178235caa088a04ac38bd8e675c

Comment 4 Sandro Bonazzola 2019-01-28 09:40:28 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 6 Sandro Bonazzola 2019-03-12 12:54:18 UTC
4.3.1 has been released, please re-target this bug as soon as possible.

Comment 7 Sandro Bonazzola 2019-03-26 10:11:24 UTC
4.3.1 has been released a while ago as RHV 4.3 Beta2.
Re-targeting to 4.3.3 for re-evaluation.


Note You need to log in before you can comment on or make changes to this bug.