Bug 1575049 - image building: detection of scala packages was broken by the switch to https
Summary: image building: detection of scala packages was broken by the switch to https
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: sahara-image-elements
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Telles Nobrega
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 15:46 UTC by Luigi Toscano
Modified: 2018-06-27 13:56 UTC (History)
7 users (show)

Fixed In Version: sahara-image-elements-8.0.1-0.20180316135145.c235e1e.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1575046
Environment:
Last Closed: 2018-06-27 13:55:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack Storyboard 2001964 None None None 2018-05-04 15:46:59 UTC
OpenStack gerrit 566342 None None None 2018-05-04 15:46:59 UTC
Red Hat Bugzilla 1575046 None None None Never
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:56:49 UTC

Internal Links: 1575046

Description Luigi Toscano 2018-05-04 15:46:59 UTC
+++ This bug was initially created as a clone of Bug #1575046 +++

Description of problem:
Apparently very recently the scala website switched to https. The current code which detects the last version of the scala packages is:

VERSION="$(curl -s --fail http://www.scala-lang.org| tr -d '\n' | sed 's/^.*<div[^<]\+scala-version">[^0-9]\+\([0-9\.\?]\+\)<.\+$/\1/')"

The website redirects to https://www.scala-lang.org but curl does not follow the redirect. So either -L should be added or the address should be switched to https. Bonus point for adding both.

This problem affects both sahara-image-create and sahara-image-pack and all versions of Sahara (but only CentOS, because the version on Ubuntu is hardcoded due to the old version of JDK on Trusty).

There is also a second issue: the code should fallback on the default version of scala (currently 2.11.6) and not fail globally.


Version-Release number of selected component (if applicable):
(all versions, including the current packages:
sahara-image-elements-8.0.1-0.20180316135144.c235e1e.el7ost
)


Steps to Reproduce:
run sahara-image-create according the instructions to create a mapr 5.2.0 image.
See it fail when it should install Scala packages.

Comment 4 Luigi Toscano 2018-05-09 12:50:24 UTC
The scala version is now detected and the scala package is installed during the creation of the image.

Verified with:
sahara-image-elements-8.0.1-0.20180316135145.c235e1e.el7ost
diskimage-builder-2.13.0-1.el7ost
dib-utils-0.0.11-1.el7ost

Comment 7 errata-xmlrpc 2018-06-27 13:55:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.