Bug 1575050 - docker-registry pod does not uniformly use hostnames - docker push fails with proxy config[backport]
Summary: docker-registry pod does not uniformly use hostnames - docker push fails with...
Keywords:
Status: CLOSED DUPLICATE of bug 1511870
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 15:51 UTC by mmariyan
Modified: 2018-05-08 14:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-08 14:24:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description mmariyan 2018-05-04 15:51:51 UTC
Description of problem:

Its regarding the Bugzilla[0]its reported in 3.6 and the fix is available for 3.9! is there bugfix is available for 3.7 version?

[0]https://bugzilla.redhat.com/show_bug.cgi?id=1504464

Comment 1 Scott Dodson 2018-05-08 14:21:04 UTC
Yes, openshift-ansible-3.7.31-1 and later should add the kubernetes service address to the no_proxy list for the registry. If for any reason this has not been done you can edit the environment variable and append the kube service ip address like so:

oc env dc/docker-registry NO_PROXY=172.30.0.1,cluster.local,etc

Comment 2 Scott Dodson 2018-05-08 14:24:57 UTC

*** This bug has been marked as a duplicate of bug 1511870 ***


Note You need to log in before you can comment on or make changes to this bug.