Bug 1575056 - Virtual Datacenter subscription unavailable to re-registering hosts
Summary: Virtual Datacenter subscription unavailable to re-registering hosts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Subscriptions - virt-who
Version: 6.3.1
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On: 1578039 1592281
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 16:05 UTC by Taft Sanders
Modified: 2019-08-12 16:11 UTC (History)
23 users (show)

Fixed In Version: candlepin-2.1.17-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1578039 1596343 (view as bug list)
Environment:
Last Closed: 2018-08-22 20:07:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3461671 0 None None None 2018-05-28 20:41:28 UTC
Red Hat Product Errata RHBA-2018:2550 0 None None None 2018-08-22 20:07:47 UTC

Description Taft Sanders 2018-05-04 16:05:46 UTC
Description of problem:
Customers are reporting client systems are unable to access the guest virtual datacenter subscription (VDC) when registering to a Satellite. Upon registering guest to host mapping does not show on the client details page for the content host. Rest

Version-Release number of selected component (if applicable):
20.4

How reproducible:
So far I have not been able to reproduce internally with KVM environment. Both reporting customers have VMWare virtualization.

Steps to Reproduce:
1. Register client system to Satellite via any method and try to attach VDC guest subscription (none available)

Actual results:
No VDC guest subscription available

Expected results:
VDC guest subscription available and attaches

Additional info:
Testing with virt-who versions 20.4 and 21.5 with the same results. Issue appears to be with Satellite 6.3.1 and VMWare

Comment 1 wclark 2018-05-04 17:24:04 UTC
Please find the below additional information regarding this issue:

1. In both cases where this has been observed so far, virt-who is not run on Satellite but on an external VM... that may or may not be relevant to the issue but I felt it was worth mentioning.

2. We can observe that all hypervisors are reported in Satellite WebUI, all hypervisors have VDC entitlements, and each VM is reported on the correct hypervisor, but for each hypervisor there are some VMs which can get the derived entitlement and some VMs which cannot.

3. For the VMs which cannot get the child entitlement, unregistering and re-registering that VM without re-running virt-who results in that VM coming back showing *not reported on any hypervisor*.

4. At least one customer is reporting that many VMs previously had an entitlement but have now lost the entitlement and are behaving the same as the VMs which could not get an entitlement in the first place.

5. We have observed no instances so far in which a VM that lost its entitlement or was unable to get one in the first place, was later able to get an entitlement. Re-running virt-who does however result in these VMs being reported as guests of the correct hypervisor, but they still cannot get the entitlement.

If there are any questions or any additional data needed please let me know and I can call the customer directly to inquire.

Comment 3 Barnaby Court 2018-05-07 12:29:27 UTC
wclark, can you get a copy of the archive generated by "rhsm-debug system" from one of the guests that is unable to consume the VDC subscription? Thanks

Comment 16 Jitendra Yejare 2018-06-18 10:50:51 UTC
This bug verification is been blocked by another bug - 1592281. Will verify once that bug is fixed.

Comment 17 vijsingh 2018-07-02 09:23:26 UTC
(In reply to Jitendra Yejare from comment #16)
> This bug verification is been blocked by another bug - 1592281. Will verify
> once that bug is fixed.

Hello  Jitendra Yejare,

Could you please provide some more details on it ,  how this bug is blocked by another bug - 1592281 ? as current state on this Bug [1575056] is in "POST" state.



Thanks,

Comment 19 Jitendra Yejare 2018-07-04 06:59:09 UTC
Vijay,

To verify this bug we as QE use docker based hypervisor and guests. To create the virt-who guests and hypervisor on satellite the json file gets uploaded to the satellite through API call which is not working and hence the bug is raised 1592281. And hence this bug is depends on that one.

When I commented the comment 16, the bug was on ON_QA and later its moved to POST. You can see mike has changed the state of a bug.

Comment 20 Jitendra Yejare 2018-07-30 15:09:07 UTC
Verified!

@ Satellite 6.4 snap 14

Steps:

1. Registered 25 virt-who guests to satellite.
2. Attempt to attach VDC subscriptions to all of them through bulk select and attach method from UI.

Behavior:

1. The hosts are registered to satellite.
2. Selected all virt-who guests for bulk attach and observed VDC subscriptions are available to attach.
3. VDC Subscriptions are attached to all virt-who guests.

Comment 22 Jitendra Yejare 2018-08-01 06:48:31 UTC
Hi,

The Testing has been done in only one that is in Default Org. The hypervisor and the guests were registered to a default org only.

Comment 25 errata-xmlrpc 2018-08-22 20:07:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2550


Note You need to log in before you can comment on or make changes to this bug.