Bug 1575059 - past nftables in EPEL7 had a Epoch, nftables in RHEL7.5 does not
Summary: past nftables in EPEL7 had a Epoch, nftables in RHEL7.5 does not
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nftables
Version: 7.5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Phil Sutter
QA Contact: Tomas Dolezal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 16:15 UTC by Kevin Stange
Modified: 2018-10-30 10:38 UTC (History)
6 users (show)

Fixed In Version: nftables-0.8-10.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:38:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3154 None None None 2018-10-30 10:38:36 UTC

Description Kevin Stange 2018-05-04 16:15:00 UTC
Description of problem:

Since the EL 7.5 release, a new version of libnftnl is provided (libnftnl.so.7) which cannot be updated because current nftables from EPEL requires libnftnl.so.4.

Version-Release number of selected component (if applicable):

nftables-0.6-1.el7.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Install nftables on EL7.4
2. Attempt to upgrade to 7.5 via yum

Actual results:

Error: Package: 1:nftables-0.6-1.el7.x86_64 (@epel)
           Requires: libnftnl.so.4(LIBNFTNL_4)(64bit)
           Removing: libnftnl-1.0.6-6.el7.x86_64 (@base)
               libnftnl.so.4(LIBNFTNL_4)(64bit)
           Updated By: libnftnl-1.0.8-1.el7.x86_64 (centos7-x86_64-cr)
              ~libnftnl.so.7(LIBNFTNL_5)(64bit)
           Available: libnftnl-1.0.6-1.el7.x86_64 (centos7-x86_64)
               libnftnl.so.4(LIBNFTNL_4)(64bit)
Error: Package: 1:nftables-0.6-1.el7.x86_64 (@epel)
           Requires: libnftnl.so.4(LIBNFTNL_4.1)(64bit)
           Removing: libnftnl-1.0.6-6.el7.x86_64 (@base)
               libnftnl.so.4(LIBNFTNL_4.1)(64bit)
           Updated By: libnftnl-1.0.8-1.el7.x86_64 (centos7-x86_64-cr)
               Not found
           Available: libnftnl-1.0.6-1.el7.x86_64 (centos7-x86_64)
               libnftnl.so.4(LIBNFTNL_4.1)(64bit)
Error: Package: 1:nftables-0.6-1.el7.x86_64 (@epel)
           Requires: libnftnl.so.4()(64bit)
           Removing: libnftnl-1.0.6-6.el7.x86_64 (@base)
               libnftnl.so.4()(64bit)
           Updated By: libnftnl-1.0.8-1.el7.x86_64 (centos7-x86_64-cr)
              ~libnftnl.so.7()(64bit)
           Available: libnftnl-1.0.6-1.el7.x86_64 (centos7-x86_64)
               libnftnl.so.4()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

Successful installation.

Additional info:

Comment 1 Kevin Fenzi 2018-05-05 01:12:45 UTC
Odd. nftables and libnftnl in epel7 were both retired when they were added to rhel7. They are no longer in epel7 repos that I can see. 

Perhaps you have a install with one of the old/no longer shipped nftables installled? It should upgrade I would expect (all the rhel7 versions are newer than this old epel7 version). 

Check also for excludes ?

Comment 2 Kevin Stange 2018-05-07 17:09:45 UTC
Just so this bug is not without an answer:

nftables-0.6-1.el7.x86_64 from EPEL had epoch of 1
nftables-0.8-7.el7.x86_64 from EL7 has epoch of 0

My system therefore saw the older version as an upgrade.  Running a "downgrade" fixed this issue.  Thanks for providing the needed context.

Comment 3 Kevin Fenzi 2018-05-07 20:54:21 UTC
Ah ha. Yes indeed. 

I'm going to move this over to rhel 7.5 maintainers. 

They may wish to document this, do nothing or add an Epoch to the rhel package.

Comment 10 errata-xmlrpc 2018-10-30 10:38:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3154


Note You need to log in before you can comment on or make changes to this bug.