Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1575091 - Mate panel eats ram and CPU when wine apps display tray icons.
Summary: Mate panel eats ram and CPU when wine apps display tray icons.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-panel
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 18:07 UTC by Davide Repetto
Modified: 2018-08-16 08:05 UTC (History)
3 users (show)

Fixed In Version: mate-panel-1.20.3-1.fc27 mate-panel-1.20.3-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-15 19:19:15 UTC
Type: Bug


Attachments (Terms of Use)
desktop with system monitor (590.25 KB, image/jpeg)
2018-05-04 18:07 UTC, Davide Repetto
no flags Details
My own Mate-Panel config (15.55 KB, text/plain)
2018-05-05 04:36 UTC, Davide Repetto
no flags Details
Installed Packages (134.27 KB, text/plain)
2018-05-05 04:40 UTC, Davide Repetto
no flags Details
My Full Mate Config (21.64 KB, text/plain)
2018-05-05 04:42 UTC, Davide Repetto
no flags Details
fpaste --sysinfo (19.46 KB, text/plain)
2018-05-05 04:49 UTC, Davide Repetto
no flags Details

Description Davide Repetto 2018-05-04 18:07:10 UTC
Created attachment 1431534 [details]
desktop with system monitor

Description of problem:
=======================
Even with the machine idle, mate-panel will rack up memory usage up to 4,9GB in a few hours, while using about 12-14% CPU.

After it reached 4,9GB the CPU usage would drop to usual values (mostly 0%)

Version-Release:
================
mate-panel-1.20.1-6.fc28.x86_64

How reproducible:
=================
Consistently

Steps to Reproduce:
1. Normal usage of the machine or just idling
2. Check CPU usage
3. Check memory usage after a few hours.


Other info:
===========
For Reference: my machine has 16GB ram, dual core AMD Athlon XP

Comment 1 Wolfgang Ulbrich 2018-05-04 18:56:19 UTC
Can you please give more info?
Does it happen with previous panel version?
Was is a new installation?
etc.?
Please provide as much infos as possible, because my cristal ball is broken ;)

Comment 2 Davide Repetto 2018-05-05 04:36:54 UTC
Created attachment 1431744 [details]
My own Mate-Panel config

Comment 3 Davide Repetto 2018-05-05 04:38:15 UTC
(In reply to Wolfgang Ulbrich from comment #1)
> Can you please give more info?
Happily. :)

> Does it happen with previous panel version?
Never happened before. All was ok up to the latest Fedora 27 updates.

> Was is a new installation?
It is an upgrade from Fedora 27 to Fedora 28.

> etc.?
> Please provide as much infos as possible, because my cristal ball is broken
> ;)

I will give you something in the attachments... Hit me if you need more!

Comment 4 Davide Repetto 2018-05-05 04:40:26 UTC
Created attachment 1431745 [details]
Installed Packages

Comment 5 Davide Repetto 2018-05-05 04:42:17 UTC
Created attachment 1431746 [details]
My Full Mate Config

Comment 6 Davide Repetto 2018-05-05 04:49:02 UTC
Created attachment 1431747 [details]
fpaste --sysinfo

Comment 7 Davide Repetto 2018-05-05 04:52:05 UTC
Please note that I did at least one "dnf upgrade" in between opening the ticket and filling this request.

Comment 8 Wolfgang Ulbrich 2018-05-05 05:28:25 UTC
Ok, you did an upgrade from f27 to f28.
And was f27 already updated to MATE 1.20?
I need to know which panel version was running before you noticed the issue.
Because f28 started with several updates for the panel.
So did you update the panel from last f27 version to current f28 panel version?
'dnf history' and
'dnf history info <id>'
should give you the information.

Comment 9 Wolfgang Ulbrich 2018-05-05 06:01:53 UTC
Btw. Do you have a chance to test this with a fresh new user account ?
Without changing panel conf and adding applets.

Comment 10 Davide Repetto 2018-05-07 09:02:10 UTC
I did some additional testing and the condition causing this always-growing memory usage is the presence of at least one tray icon of a windows program (running under wine).

I almost always have eMule running, so... (Time to change the description of this bug.)

BTW, the new record of memory eaten by the panel is 11,6GB in 24 ours with UltraVNC in listening mode and eMule, both Active.

Comment 11 Davide Repetto 2018-05-07 09:09:34 UTC
P.S.:
I am able to reproduce consistently on a clean install on VirtualBox, qemu.
Of course you need to install wine and a windows program with a tray icon, as for example eMule, UltraVNC.

Comment 12 Wolfgang Ulbrich 2018-05-07 12:04:34 UTC
I don't use wine
Can you please answer my questions from https://bugzilla.redhat.com/show_bug.cgi?id=1575091#c8  ?

Comment 13 Wolfgang Ulbrich 2018-05-07 12:35:55 UTC
I changed a build configure option with MATE-1.20. For this reason i need to know the exact version from previous mate-panel build, to be sure.
https://src.fedoraproject.org/cgit/rpms/mate-panel.git/commit/?h=f28&id=7978a516a6a7f5cfdd6472006b8921b0cb487744

Comment 14 Davide Repetto 2018-05-08 17:59:28 UTC
> Ok, you did an upgrade from f27 to f28.
> And was f27 already updated to MATE 1.20?
> I need to know which panel version was running before you noticed the issue.
> Because f28 started with several updates for the panel.
> So did you update the panel from last f27 version to current f28 panel version?
> 'dnf history' and
> 'dnf history info <id>'
> should give you the information.

Unfortunately I already discarded the dnf history of f27, so instead of answering the question straight away I've done a little bit of bisecting:

with mate-panel up to 1.20.0-1 memory usage is normal.
The problems start with mate-panel-1.20.1-1 in both f28 and f27.

In koji I found no in-betweens from 1.20.0-1 to 1.20.1-1. So I called it a day and posted the results here. But let me know if you have any intermediate version that you want me to try.

Comment 15 Wolfgang Ulbrich 2018-05-08 18:10:40 UTC
So 1.20.0-4 for f28 is fine?
https://koji.fedoraproject.org/koji/buildinfo?buildID=1052868
Maybe this commit causes the problem ?
https://src.fedoraproject.org/cgit/rpms/mate-panel.git/commit/?h=f28&id=7978a516a6a7f5cfdd6472006b8921b0cb487744
This was with 1.20.0-2

More builds you will find at koji 
https://koji.fedoraproject.org/koji/packageinfo?packageID=14801

Comment 16 Wolfgang Ulbrich 2018-05-08 18:39:04 UTC
To shorten the process. Does this build fixes the issue for you?
https://koji.fedoraproject.org/koji/taskinfo?taskID=26851768

Comment 17 Davide Repetto 2018-05-08 23:17:02 UTC
(In reply to Wolfgang Ulbrich from comment #16)
> To shorten the process. Does this build fixes the issue for you?
> https://koji.fedoraproject.org/koji/taskinfo?taskID=26851768

Yes. The new build fixes the issue.

Comment 18 Wolfgang Ulbrich 2018-05-09 05:13:32 UTC
This is good for you but bad in general.
Switching back to configure flag --with-in-process-applets=none
isn't so good if you're using a HIDPI monitor.
As MATE suport this feature with 1.20 i switched to 
--with-in-process-applets=all

Can you please file out an upstream report?
This needs be fixed by them, as in-process-applets is also important for a future support of wayland.
In the meanwhile i can switch back to the old build option if they found no solution.

Comment 19 Wolfgang Ulbrich 2018-05-09 05:47:15 UTC
To be be shure that it isn't caused by https://github.com/mate-desktop/mate-panel/commit/d02fcc5c27e142f7d232d5239105e87e9fe27e6e    ,
which is the only commit for tray applet between 1.20.0 and 1.20.1.
Can you please test this build please?
https://koji.fedoraproject.org/koji/taskinfo?taskID=26853824
I reverted the commit in this build and use --with-in-process-applets=all again.
Thank you

Comment 20 Davide Repetto 2018-05-10 12:22:10 UTC
(In reply to Wolfgang Ulbrich from comment #19)
> To be be shure that it isn't caused by
> https://github.com/mate-desktop/mate-panel/commit/
> d02fcc5c27e142f7d232d5239105e87e9fe27e6e    ,
> which is the only commit for tray applet between 1.20.0 and 1.20.1.
> Can you please test this build please?
> https://koji.fedoraproject.org/koji/taskinfo?taskID=26853824
> I reverted the commit in this build and use --with-in-process-applets=all

Yep. This 1.20.1-9 build has the problem.

Comment 21 Wolfgang Ulbrich 2018-05-10 12:58:09 UTC
Ok, that means that memleak happens if we build the panel with
--with-in-process-applets=all
This is better for HIDPI resolution support.

Can you please file out an upstream report?
This needs be fixed by them, as in-process-applets is also important for a future support of wayland.

Comment 22 Dmitry Tantsur 2018-05-22 08:29:47 UTC
Hi all,

Was the bug filed upstream? I think I see the same after some update:

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
 1890 dtantsur  20   0 12.100g 6.286g   6340 S  14.6 56.3 193:21.75 mate-panel

I can file if you tell me which information I have to provide. Note that I don't have wine though, but I do have a few apps with tray icons.

Comment 23 Dmitry Tantsur 2018-05-22 08:34:26 UTC
Wild guess: in my case it may be caused by the Audacious tray icon. I hadn't seen this problem before I started actively using, nor is my wife experiencing in a similar environment.

Comment 24 Wolfgang Ulbrich 2018-05-22 10:43:16 UTC
@Dmitry Tantsur
Are you shure that it is caused by audacious applet?
I guess audacious use Qt nowadays?
Can you please add this information to https://github.com/mate-desktop/mate-panel/issues/809 ?

Now we have a chance to debug this issue as audacious is a common application in all distros.

Comment 25 Wolfgang Ulbrich 2018-05-22 10:52:20 UTC
Btw. I switched the panel back to build applets out of process.
This should solve the problem.
f27
https://bodhi.fedoraproject.org/updates/FEDORA-2018-7cbfe6ab39
f28
https://bodhi.fedoraproject.org/updates/FEDORA-2018-f11f17bf17
But we need to debug this as building applets in process is needed for a switch to wayland in future.

Comment 26 Fedora Update System 2018-08-08 10:31:09 UTC
mate-panel-1.20.3-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-398fd67e4d

Comment 27 Fedora Update System 2018-08-08 10:31:21 UTC
mate-panel-1.20.3-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b8f25d74ad

Comment 28 Fedora Update System 2018-08-08 14:26:55 UTC
mate-panel-1.20.3-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-398fd67e4d

Comment 29 Fedora Update System 2018-08-08 17:14:56 UTC
mate-panel-1.20.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b8f25d74ad

Comment 30 Fedora Update System 2018-08-15 19:19:15 UTC
mate-panel-1.20.3-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 31 Fedora Update System 2018-08-16 08:05:50 UTC
mate-panel-1.20.3-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.