Bug 1575186 - dnf system-upgrade from FC 27 to 28 fails to pull in required glibc-langpack-XX
Summary: dnf system-upgrade from FC 27 to 28 fails to pull in required glibc-langpack-XX
Keywords:
Status: CLOSED DUPLICATE of bug 1574222
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugin-system-upgrade
Version: 28
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-05 01:18 UTC by Arne Ahrend
Modified: 2018-05-07 11:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 11:15:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Arne Ahrend 2018-05-05 01:18:25 UTC
Description of problem:
I am (and have been for many years) on a de_DE.UTF-8 system locale.
After upgrading to Fedora 28 via dnf system-upgrade gnome-terminal-server.service failed to start and shells in the "text mode" virtual consoles emitted warnings about locales.

Running 
dnf install glibc-langpack-de
resolved the issue.

Version-Release number of selected component (if applicable):
Not sure. It was the latest FC-27 version of dnf.


How reproducible:
Maybe install FC-27 from scratch, set a system locale LANG=de_DE.UTF-8
and upgrade to FC-28 using
dnf upgrade --refresh
dnf install dnf-plugin-system-upgrade
dnf system-upgrade download --refresh --releasever=25
dnf system-upgrade reboot



Steps to Reproduce:
1.
2.
3.

Actual results:
Shells in virtual consoles emitted warnings about locales (setlocale: LC_TIME: Cannot change default settings) and Gnome Terminal under Wayland fails to start.

Expected results:
Working Gnome Terminal

Additional info:
Running 
dnf install glibc-langpack-de
resolved the issue.

Comment 1 Arne Ahrend 2018-05-05 01:23:03 UTC
--releasever=25 is, of course, a typo.

--releasever=28 ist the correct parameter for upgrading.

Comment 2 Martin Hatina 2018-05-07 11:15:32 UTC

*** This bug has been marked as a duplicate of bug 1574222 ***


Note You need to log in before you can comment on or make changes to this bug.