Bug 1575229 - Fedora 28 Gnome Login Crashes (xorg, wayland, classic)
Summary: Fedora 28 Gnome Login Crashes (xorg, wayland, classic)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-05 09:57 UTC by Harish Pillay
Modified: 2018-05-07 08:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-05-06 22:25:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Harish Pillay 2018-05-05 09:57:08 UTC
Description of problem:
I updated my Fedora 27 desktop via the dnf upgrade path. It downloaded all the needed packages, and got update. When I tried to login (GNOME Xorg), it kept logging me out without even showing the desktop. Tried GNOME Classic and GNOME and all failed. Both LXDE, Openbox work. 

Version-Release number of selected component (if applicable):
Fedora 28 updated via:
"dnf system-upgrade download --refresh --releasever=28"

How reproducible:
Not sure about this. 

Steps to Reproduce:
1. Not sure
2.
3.

Actual results:

I should have been able to log in via GNOME but no.

Expected results:

Crashed out without seeing the GNOME desktop

Additional info:

Right now, logged in via LXDE.

Comment 1 Harish Pillay 2018-05-06 22:25:55 UTC
Solved as per this tweet by William Henry:

https://twitter.com/ipbabble/status/993228035368235008

essentially, to remove/move .local/share/gnome-shell/extensions

Once that was done, I could log in.

Comment 2 Harish Pillay 2018-05-07 03:16:37 UTC
Just an update to this. I had two GNOME extensions installed: Show IP and Internet Radio. After removing both as per earlier comment, I then tested by adding them one by one. Internet Radio worked OK. Adding Show IP immediately crashed GNOME and I could not log back in. Had to remove the extensions and things were back to normal.


Note You need to log in before you can comment on or make changes to this bug.