Bug 1575234 - SELinux is preventing gssproxy from 'getattr' accesses on the file /usr/sbin/rpc.gssd.
Summary: SELinux is preventing gssproxy from 'getattr' accesses on the file /usr/sbin/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d6f1147aae65831ff664fd5d81e...
: 1588196 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-05 11:15 UTC by James
Modified: 2018-07-29 03:23 UTC (History)
10 users (show)

Fixed In Version: selinux-policy-3.14.1-29.fc28 selinux-policy-3.14.1-36.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-29 03:23:03 UTC
Type: ---


Attachments (Terms of Use)

Description James 2018-05-05 11:15:02 UTC
Description of problem:
SELinux is preventing gssproxy from 'getattr' accesses on the file /usr/sbin/rpc.gssd.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gssproxy should be allowed getattr access on the rpc.gssd file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gssproxy' --raw | audit2allow -M my-gssproxy
# semodule -X 300 -i my-gssproxy.pp

Additional Information:
Source Context                system_u:system_r:gssproxy_t:s0
Target Context                system_u:object_r:gssd_exec_t:s0
Target Objects                /usr/sbin/rpc.gssd [ file ]
Source                        gssproxy
Source Path                   gssproxy
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           nfs-utils-2.3.1-7.rc1.fc28.x86_64
Policy RPM                    selinux-policy-3.14.1-24.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.16.5-300.fc28.x86_64 #1 SMP Fri
                              Apr 27 17:38:36 UTC 2018 x86_64 x86_64
Alert Count                   3
First Seen                    2018-05-05 11:45:00 BST
Last Seen                     2018-05-05 12:14:11 BST
Local ID                      bee2e9d7-ba66-41f9-b17f-e7291ee3ee7b

Raw Audit Messages
type=AVC msg=audit(1525518851.889:261): avc:  denied  { getattr } for  pid=787 comm="gssproxy" path="/usr/sbin/rpc.gssd" dev="sda6" ino=6100503 scontext=system_u:system_r:gssproxy_t:s0 tcontext=system_u:object_r:gssd_exec_t:s0 tclass=file permissive=1


Hash: gssproxy,gssproxy_t,gssd_exec_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.14.1-24.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.5-300.fc28.x86_64
type:           libreport

Comment 1 Brian Naasz 2018-05-12 19:03:21 UTC
Description of problem:
I get a set of 5 AVC denials with gssproxy usually fairly quickly after a fresh boot and the start of Xwindows.   

Version-Release number of selected component:
selinux-policy-3.14.1-24.fc28.noarch

Additional info:
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.7-300.fc28.x86_64+debug
type:           libreport

Comment 2 Fedora Update System 2018-05-24 14:35:44 UTC
selinux-policy-3.14.1-29.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a74875b364

Comment 3 Fedora Update System 2018-05-25 18:42:26 UTC
selinux-policy-3.14.1-29.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a74875b364

Comment 4 James 2018-05-26 13:22:43 UTC
Description of problem:
Still some gssproxy AVCs left with selinux-policy-3.14.1-29.fc28.

Version-Release number of selected component:
selinux-policy-3.14.1-29.fc28.noarch

Additional info:
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.11-300.fc28.x86_64
type:           libreport

Comment 5 Fedora Update System 2018-05-26 20:44:17 UTC
selinux-policy-3.14.1-29.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Jan Kalina 2018-05-28 10:43:55 UTC
Description of problem:
On system boot up, gssproxy cannot access /usr/sbin/rpc.gssd.

Version-Release number of selected component:
selinux-policy-3.14.1-29.fc28.noarch

Additional info:
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.8-300.fc28.x86_64
type:           libreport

Comment 7 alex 2018-05-30 16:41:48 UTC
Description of problem:
Hi,

Running sudo mount for an NFS share. This is a Fedora 28 system joined to a FreeIPA domain which handles sudo.

Cheers,

Álex

Version-Release number of selected component:
selinux-policy-3.14.1-29.fc28.noarch

Additional info:
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.12-300.fc28.x86_64
type:           libreport

Comment 8 Jan Kalina 2018-06-01 07:00:11 UTC
Description of problem:
On bootup, in default configuration, gssproxy is prevented to access rpc.gssd.

Version-Release number of selected component:
selinux-policy-3.14.1-30.fc28.noarch

Additional info:
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.12-300.fc28.x86_64
type:           libreport

Comment 9 Martin Tessun 2018-06-16 09:11:59 UTC
Still getting the rpc.gssd getattr denial:

$ sudo ausearch -c 'gssproxy' | tail -10
type=AVC msg=audit(1529004709.157:127): avc:  denied  { getattr } for  pid=1498 comm="gssproxy" path="/usr/sbin/rpc.gssd" dev="dm-0" ino=2896245 scontext=system_u:system_r:gssproxy_t:s0 tcontext=system_u:object_r:gssd_exec_t:s0 tclass=file permissive=0
----
time->Sat Jun 16 10:58:36 2018
type=AVC msg=audit(1529139516.014:111): avc:  denied  { getattr } for  pid=1298 comm="gssproxy" path="/usr/sbin/rpc.gssd" dev="dm-0" ino=2896245 scontext=system_u:system_r:gssproxy_t:s0 tcontext=system_u:object_r:gssd_exec_t:s0 tclass=file permissive=0
----
time->Sat Jun 16 10:59:11 2018
type=AVC msg=audit(1529139551.161:310): avc:  denied  { getattr } for  pid=2500 comm="gssproxy" path="/usr/sbin/rpc.gssd" dev="dm-0" ino=2896245 scontext=system_u:system_r:gssproxy_t:s0 tcontext=system_u:object_r:gssd_exec_t:s0 tclass=file permissive=0
----
time->Sat Jun 16 10:59:12 2018
type=AVC msg=audit(1529139552.367:312): avc:  denied  { getattr } for  pid=2500 comm="gssproxy" path="/usr/sbin/rpc.gssd" dev="dm-0" ino=2896245 scontext=system_u:system_r:gssproxy_t:s0 tcontext=system_u:object_r:gssd_exec_t:s0 tclass=file permissive=0


time->Sat Jun 16 10:59:12 2018
type=AVC msg=audit(1529139552.367:312): avc:  denied  { getattr } for  pid=2500 comm="gssproxy" path="/usr/sbin/rpc.gssd" dev="dm-0" ino=2896245 scontext=system_u:system_r:gssproxy_t:s0 tcontext=system_u:object_r:gssd_exec_t:s0 tclass=file permissive=0


$ sudo rpm -q selinux-policy
selinux-policy-3.14.1-32.fc28.noarch

Comment 10 Lukas Vrabec 2018-07-03 07:32:49 UTC
commit 625878ab56bed17f46365c4c49e15b9e2f5196bb (HEAD -> rawhide, origin/rawhide, origin/HEAD)
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Tue Jul 3 09:32:22 2018 +0200

    Allow gssproxy_t domain to domtrans into gssd_t domain BZ(1575234)

Comment 11 Joe Best 2018-07-23 07:05:04 UTC
Description of problem:
dnf upgrade from 27 to 28, after reboot, got this message.

Version-Release number of selected component:
selinux-policy-3.14.1-32.fc28.noarch

Additional info:
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.17.7-200.fc28.x86_64
type:           libreport

Comment 12 Fedora Update System 2018-07-25 22:28:45 UTC
selinux-policy-3.14.1-36.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1050fb248b

Comment 13 Fedora Update System 2018-07-26 16:31:07 UTC
selinux-policy-3.14.1-36.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1050fb248b

Comment 14 alex 2018-07-27 14:29:39 UTC
selinux-policy-3.14.1-36.fc28 solves the issue for me, I have given positive feedback

Comment 15 Brian Naasz 2018-07-27 19:29:22 UTC
Confirmed that it works for me as well.

Comment 16 Lukas Vrabec 2018-07-27 19:33:56 UTC
*** Bug 1588196 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2018-07-29 03:23:03 UTC
selinux-policy-3.14.1-36.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.