Bug 1575236 - SELinux is preventing gssproxy from using the 'sys_ptrace' capabilities.
Summary: SELinux is preventing gssproxy from using the 'sys_ptrace' capabilities.
Keywords:
Status: CLOSED DUPLICATE of bug 1578097
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:0e4ab9d90bedb32738e68ed3efd...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-05 11:16 UTC by James
Modified: 2018-05-21 16:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-21 16:13:40 UTC
Type: ---


Attachments (Terms of Use)

Description James 2018-05-05 11:16:08 UTC
Description of problem:
SELinux is preventing gssproxy from using the 'sys_ptrace' capabilities.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gssproxy should have the sys_ptrace capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gssproxy' --raw | audit2allow -M my-gssproxy
# semodule -X 300 -i my-gssproxy.pp

Additional Information:
Source Context                system_u:system_r:gssproxy_t:s0
Target Context                system_u:system_r:gssproxy_t:s0
Target Objects                Unknown [ capability ]
Source                        gssproxy
Source Path                   gssproxy
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.1-24.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.16.5-300.fc28.x86_64 #1 SMP Fri
                              Apr 27 17:38:36 UTC 2018 x86_64 x86_64
Alert Count                   2
First Seen                    2018-05-05 11:45:00 BST
Last Seen                     2018-05-05 12:14:12 BST
Local ID                      964fd12b-ad33-44b8-96c6-9b44142a0945

Raw Audit Messages
type=AVC msg=audit(1525518852.9:262): avc:  denied  { sys_ptrace } for  pid=787 comm="gssproxy" capability=19  scontext=system_u:system_r:gssproxy_t:s0 tcontext=system_u:system_r:gssproxy_t:s0 tclass=capability permissive=1


Hash: gssproxy,gssproxy_t,gssproxy_t,capability,sys_ptrace

Version-Release number of selected component:
selinux-policy-3.14.1-24.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.5-300.fc28.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2018-05-21 16:13:40 UTC

*** This bug has been marked as a duplicate of bug 1578097 ***


Note You need to log in before you can comment on or make changes to this bug.