Bug 1575265 - Printer prints nothing
Summary: Printer prints nothing
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 28
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-05 14:10 UTC by marcikova.m91
Modified: 2019-04-03 06:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-02 19:35:05 UTC
Type: Bug


Attachments (Terms of Use)
Troubleshoot txt (33.29 KB, text/plain)
2018-05-05 14:10 UTC, marcikova.m91
no flags Details
demanded zipfile (12.29 KB, application/zip)
2018-08-05 11:13 UTC, marcikova.m91
no flags Details
updated troubleshoot (32.33 KB, text/plain)
2018-08-11 06:07 UTC, marcikova.m91
no flags Details

Description marcikova.m91 2018-05-05 14:10:12 UTC
Created attachment 1431925 [details]
Troubleshoot txt

Description of problem: 
When I try to print in LibreOffice, an error "Could not start printer. Please check your printer configuration" occurs. Troubleshoot tool tried to print a test page but LED on the printer just flashed and nothing happened. I tried everything I found on the websites, nothing helped.


Version-Release number of selected component (if applicable): 5 and 6

Steps to Reproduce:
1. Try to print page via LibreOffice

Actual results: mentioned error occurs or OS thinks the page was printed succesfully.

Expected results: print the document

Comment 1 Caolan McNamara 2018-05-05 20:48:24 UTC
Try exporting the document to pdf from libreoffice, open the pdf in evince and try and print from there and see if that also fails. If that fails as well then the problem is presumably some general problem with printing and not a specific libreoffice printing problem.

Comment 2 marcikova.m91 2018-05-05 21:06:21 UTC
(In reply to Caolan McNamara from comment #1)
> Try exporting the document to pdf from libreoffice, open the pdf in evince
> and try and print from there and see if that also fails. If that fails as
> well then the problem is presumably some general problem with printing and
> not a specific libreoffice printing problem.

I tried and it also failed. As I claimed in my report, I failed to print anything so far (a test page, a web page, ...). The only difference in LibreOffice is that an error occurs when I try to print something.
If you are not willing to help me with the problem, could you please at least direct me to whom should I turn? 
Thank you very much.

Comment 3 Zdenek Dohnal 2018-05-09 09:45:03 UTC
Hi, 

thank you for reporting this issue! Would you mind following https://fedoraproject.org/wiki/How_to_debug_printing_problems#Filing_a_bug_report and attach mentioned files in zip?

Comment 4 marcikova.m91 2018-08-05 11:13:48 UTC
Created attachment 1473451 [details]
demanded zipfile

I did my best to collect demanded data (I am just a begginer and also not that good in technical english). If anything misses, please tell me and I will add it.

Comment 5 Zdenek Dohnal 2018-08-06 15:47:39 UTC
Thank you for the files! Your printer is installed as only generic text-only printer - is it an output of automatic printer detection or did you manually create the printer? I just want to know if automatic printer installation is broken in this issue too.
I did a little research and your printer should be 'kind of' supported (you need to use driver for different printer - Samsung SCX 4200) by package splix. Would you mind trying if you have the package installed by:

$ rpm -q splix

If you don't have it installed, would you mind installing it?

If you do have it installed, then you can try it install it manually in CUPS web interface at web link localhost:631 (you need to have cups service running - check it by 'systemctl status cups', if it isn't running, start it). 
There you click on Administration -> Add printer -> (enter your root and its password) -> and follow the dialog. 
You are interested in 'Local printers', whose are usb connected printers - there should be your printer too. 
Follow the process until you reach selecting a model of printer - there you should find Samsung SCX 4200, if you have splix package installed, so select it.
Finish the installation and the printer should work now. If not, we will look into it more.

Comment 6 marcikova.m91 2018-08-11 06:06:21 UTC
Thank you for response.

It is an output of automatic printer detection. I tried to find a proper driver, but I couldn't find the one for SCX-3405W so I didn't install any other. 

I have installed this splix package:

splix-2.0.1-0.36.20130902svn.fc28.x86_64


I followed your instructions and installed the driver for SCX 4200, but with splix 2.0.0 (it was the only option which included splix driver).

I finished the process and tried to print some pages from a file. The printer printed on a paper sheet this error:

SPL ERROR - Please use the proper driver.

POSITION: 0x0 (0)

SYSTEM: h6fw/xl_op

LINE: 188

VERSION: SPL 5.58.01 06-27-2012

I run the installed printer driver through system config printer troubleshooter. Nothing was changed, but at least I attached for you a new troubleshoot log.

Comment 7 marcikova.m91 2018-08-11 06:07:11 UTC
Created attachment 1475171 [details]
updated troubleshoot

Comment 8 Zdenek Dohnal 2018-08-13 14:54:41 UTC
As you said, there isn't a driver for this exact printer model. Did the printer work fine in the past?
If the printer didn't work before, only advice I can give is to try other Samsung drivers from splix and see, if any of them is usable.

Comment 9 marcikova.m91 2019-04-02 19:35:05 UTC
Hello, I just somehow found out how to make the printer work. 
This is how I proceeded:

Accidentaly I found this page with the driver: https://www.samsungsupportus.com/2017/05/samsung-scx-3405w-driver-download.html
So I installed it. Nothing happened, even after restart - no printers were added.

So I run system-config-printer. Then I clicked on Server -> Connect -> There was an option "/var/run/cups/cups.sock" to choose. I did so and then clicked on "Connection". Now the button "Add" was available to click on in the main window of system-config-printer. It finally found the printer connected via USB, automatically downloaded drivers, offered me to change the name and description for the printer and it was done. Printer test page was printed succesfully, documents from LibreOffice too.

Comment 10 Zdenek Dohnal 2019-04-03 06:09:26 UTC
Thank you for letting me know!


Note You need to log in before you can comment on or make changes to this bug.