Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1575271 - CPU frequency goes high after recovering from system suspension
Summary: CPU frequency goes high after recovering from system suspension
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-05 14:43 UTC by daniele356
Modified: 2018-05-21 16:52 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-21 16:52:03 UTC
Type: Bug


Attachments (Terms of Use)

Description daniele356 2018-05-05 14:43:07 UTC
Description of problem:
I noticed that my CPU frequency goes high after waking up my system from suspension even if no process running. It oblige me to force system shutdown and reboot.
P.S. gnome-system-monitor doesn't show me these results but the "CPU Frequency Manager"(https://extensions.gnome.org/extension/945/cpu-power-manager/) GNOME Shell Extension does.

Version-Release number of selected component (if applicable):
4.16.5-300

How reproducible:
Suspend the system and wake It up.

Steps to Reproduce:
1. Suspend the current session
2. Wake It up

Actual results:
CPU frequency goes high.

Expected results:
CPU frequency changes slightly.

Additional info:
I own an Asus Laptop (K Series) with an Intel Core i7 (6th generation) as CPU.

Comment 1 daniele356 2018-05-05 14:45:39 UTC
The GNOME Shell extension name is "CPU Power Manager" and not "CPU Frequency Manager".

Comment 2 daniele356 2018-05-11 16:54:55 UTC
This situation is becoming really annoying, I can't suspend the system because I can't shutdown It after I resumed the session; so I'm obliged to lock the session instead of suspend It but this consumes more battery and this is even more annoying.

Comment 3 daniele356 2018-05-21 16:52:03 UTC
I've just upgraded the kernel to version 4.16.8-300.fc28.x86_64 and now the problem is solved!


Note You need to log in before you can comment on or make changes to this bug.