Bug 1575292 - [abrt] freeorion: std::__replacement_assert(): freeorion killed by SIGABRT
Summary: [abrt] freeorion: std::__replacement_assert(): freeorion killed by SIGABRT
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freeorion
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Link Dupont
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:e8610a0bc717428b085fad0b3ab...
Keywords:
: 1577956 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-05 18:40 UTC by a.vogt@linexus.de
Modified: 2018-07-11 20:17 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-07-11 19:29:09 UTC


Attachments (Terms of Use)
File: backtrace (71.75 KB, text/plain)
2018-05-05 18:40 UTC, a.vogt@linexus.de
no flags Details
File: cgroup (399 bytes, text/plain)
2018-05-05 18:40 UTC, a.vogt@linexus.de
no flags Details
File: core_backtrace (9.47 KB, text/plain)
2018-05-05 18:40 UTC, a.vogt@linexus.de
no flags Details
File: cpuinfo (1.26 KB, text/plain)
2018-05-05 18:40 UTC, a.vogt@linexus.de
no flags Details
File: dso_list (8.63 KB, text/plain)
2018-05-05 18:40 UTC, a.vogt@linexus.de
no flags Details
File: environ (6.21 KB, text/plain)
2018-05-05 18:40 UTC, a.vogt@linexus.de
no flags Details
File: limits (1.29 KB, text/plain)
2018-05-05 18:40 UTC, a.vogt@linexus.de
no flags Details
File: maps (63.22 KB, text/plain)
2018-05-05 18:40 UTC, a.vogt@linexus.de
no flags Details
File: mountinfo (3.58 KB, text/plain)
2018-05-05 18:40 UTC, a.vogt@linexus.de
no flags Details
File: open_fds (1.51 KB, text/plain)
2018-05-05 18:40 UTC, a.vogt@linexus.de
no flags Details
File: proc_pid_status (1.26 KB, text/plain)
2018-05-05 18:40 UTC, a.vogt@linexus.de
no flags Details

Description a.vogt@linexus.de 2018-05-05 18:40:21 UTC
Description of problem:
I started freeorion from the command line and got: 

$ freeorion
/usr/include/c++/8/bits/stl_vector.h:950: std::vector<_Tp, _Alloc>::const_reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) const [with _Tp = float; _Alloc = std::allocator<float>; std::vector<_Tp, _Alloc>::const_reference = const float&; std::vector<_Tp, _Alloc>::size_type = long unsigned int]: Assertion '__builtin_expect(__n < this->size(), true)' failed.
Aborted (core dumped)

The issue is a 100% reproducible on my machine. 

Version-Release number of selected component:
freeorion-0.4.7.1-8.fc28

Additional info:
reporter:       libreport-2.9.5
backtrace_rating: 4
cmdline:        freeorion
crash_function: std::__replacement_assert
executable:     /usr/bin/freeorion
journald_cursor: s=fe61f6a78d81408abe8e42d016a3275e;i=410351;b=b45aa7f520bf4889a6e36764cbd9c954;m=6c9dc3c3c;t=56b77d121d363;x=6472be355179c392
kernel:         4.16.5-300.fc28.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 a.vogt@linexus.de 2018-05-05 18:40:27 UTC
Created attachment 1432024 [details]
File: backtrace

Comment 2 a.vogt@linexus.de 2018-05-05 18:40:28 UTC
Created attachment 1432025 [details]
File: cgroup

Comment 3 a.vogt@linexus.de 2018-05-05 18:40:29 UTC
Created attachment 1432026 [details]
File: core_backtrace

Comment 4 a.vogt@linexus.de 2018-05-05 18:40:31 UTC
Created attachment 1432027 [details]
File: cpuinfo

Comment 5 a.vogt@linexus.de 2018-05-05 18:40:32 UTC
Created attachment 1432028 [details]
File: dso_list

Comment 6 a.vogt@linexus.de 2018-05-05 18:40:34 UTC
Created attachment 1432029 [details]
File: environ

Comment 7 a.vogt@linexus.de 2018-05-05 18:40:35 UTC
Created attachment 1432030 [details]
File: limits

Comment 8 a.vogt@linexus.de 2018-05-05 18:40:37 UTC
Created attachment 1432031 [details]
File: maps

Comment 9 a.vogt@linexus.de 2018-05-05 18:40:38 UTC
Created attachment 1432032 [details]
File: mountinfo

Comment 10 a.vogt@linexus.de 2018-05-05 18:40:40 UTC
Created attachment 1432033 [details]
File: open_fds

Comment 11 a.vogt@linexus.de 2018-05-05 18:40:41 UTC
Created attachment 1432034 [details]
File: proc_pid_status

Comment 12 hugo.thiessard 2018-05-14 13:58:40 UTC
*** Bug 1577956 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2018-06-30 05:32:59 UTC
freeorion-0.4.7.1-9.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-522442a73f

Comment 14 Fedora Update System 2018-06-30 05:33:08 UTC
freeorion-0.4.7.1-9.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f566c3cfb1

Comment 15 Link Dupont 2018-06-30 05:39:17 UTC
I've been working with upstream on this issue recently. The upstream issue can be found on their Github project[1].

Their developers believe this crash is caused by the inclusion of _GLIBCXX_ASSERTIONS in the CXXFLAGS. They have been looking into patching the assertion failures, and suggested I try a patch set[2]. This patch set does fix this specific assertion failure, allowing the game to once again launch. This patch set is by no means complete however. I've submitted an update to the testing repos that includes the patches as they exist today[2]. Please give those packages a try and report any crashes you encounter.

1: https://github.com/freeorion/freeorion/issues/2182#issuecomment-401331585
2: https://github.com/freeorion/freeorion/compare/v0.4.7.1...dbenage-cx:fix-2182_backport-v0.4.7.1.patch

Comment 16 Fedora Update System 2018-07-01 02:53:58 UTC
freeorion-0.4.7.1-10.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-522442a73f

Comment 17 Fedora Update System 2018-07-01 05:06:47 UTC
freeorion-0.4.7.1-10.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f566c3cfb1

Comment 18 Fedora Update System 2018-07-11 19:29:09 UTC
freeorion-0.4.7.1-10.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2018-07-11 20:17:41 UTC
freeorion-0.4.7.1-10.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.