Bug 1575294 - lease recall callback should be avoided on closed
Summary: lease recall callback should be avoided on closed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-05 18:43 UTC by Thomas H.P. Andersen
Modified: 2018-06-20 18:06 UTC (History)
1 user (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-20 18:06:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Thomas H.P. Andersen 2018-05-05 18:43:15 UTC
Description of problem:
Due to a missing curly brace the lease recall callback will happen on GLFD_CLOSE

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-05-05 18:46:42 UTC
REVIEW: https://review.gluster.org/19967 (gfapi: acutally avoid recall callback when closed) posted (#1) for review on master by Thomas H.P. Andersen

Comment 2 Worker Ant 2018-05-06 11:25:09 UTC
COMMIT: https://review.gluster.org/19967 committed in master by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- gfapi: acutally avoid recall callback when closed

Due to missing curly braces we end up calling the callback
function even when state is GLFD_CLOSE. This patch adds the
curly braces so both the log and actual callback is skipped.

  Introduced in 19568 in commit b04066721bf4a240f61b83bd87bbb27437c5fe4f

Change-Id: I0b15cfe222841cfcb12f17723284acb3838d64d7
fixes: bz#1575294
Signed-off-by: Thomas Hindoe Paaboel Andersen <phomes@gmail.com>

Comment 3 Shyamsundar 2018-06-20 18:06:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.