Bug 1575381 - gluster volume heal info prints extra newlines
Summary: gluster volume heal info prints extra newlines
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: selfheal
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-06 12:52 UTC by Michael Adam
Modified: 2018-10-23 15:07 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 15:07:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Michael Adam 2018-05-06 12:52:10 UTC
Description of problem:

The output of "gluster volume heal <volume> info" is clobbered with extra
new lines when messages "- Possibly undergoing heal" or " - Is in split-brain"
are printed for listed files:

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to reproduce:

In a situation with files in heal or split brain, run "gluster volume heal <volname> info.

Actual results:

Output looks like this:

...
foo1
foo2
foo3 - Possibly undergoing heal

foo4
foo5 - Is in split-brain

foo6
foo7
...


Expected results:

Output should look like this:

...
foo1
foo2
foo3 - Possibly undergoing heal
foo4
foo5 - Is in split-brain
foo6
foo7
...




Additional info:

Comment 1 Worker Ant 2018-05-06 13:05:23 UTC
REVIEW: https://review.gluster.org/19968 (heal: improve output of heal info) posted (#1) for review on master by Michael Adam

Comment 2 Worker Ant 2018-05-08 00:17:49 UTC
COMMIT: https://review.gluster.org/19968 committed in master by "Pranith Kumar Karampuri" <pkarampu@redhat.com> with a commit message- heal: improve output of heal info

The output of "gluster volume heal <volume> info" is clobbered with
extra new lines when messages "- Possibly undergoing heal" or " - Is in
split-brain" are printed for listed files.

This patch fixes the output by removing the extra new lines.

Bug: 1575381

Change-Id: Ifb614e0fb7c85f7af3a799958d3645a2bff2b53a
fixes: bz#1575381
Signed-off-by: Michael Adam <obnox@samba.org>

Comment 3 Shyamsundar 2018-10-23 15:07:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.