Bug 1575386 (glusterfs-4.1.0) - GlusterFS 4.1.0 tracker
Summary: GlusterFS 4.1.0 tracker
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: glusterfs-4.1.0
Product: GlusterFS
Classification: Community
Component: core
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1582549
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-06 13:22 UTC by Shyamsundar
Modified: 2018-06-20 18:06 UTC (History)
3 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-20 18:06:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Shyamsundar 2018-05-06 13:22:09 UTC
Tracker for the release 4.1.0

Comment 1 Worker Ant 2018-05-07 19:56:12 UTC
REVIEW: https://review.gluster.org/19975 (core: remove experimental xlators and associated tests) posted (#1) for review on release-4.1 by Shyamsundar Ranganathan

Comment 2 João Carlos Mendes Luís 2018-05-08 12:43:34 UTC
Suggestion: Add a link to the next tracker when one is closed

Comment 3 Shyamsundar 2018-05-08 12:57:50 UTC
(In reply to João Carlos Mendes Luís from comment #2)
> Suggestion: Add a link to the next tracker when one is closed

Useful suggestion, added to the release task list, thanks!

Comment 4 Worker Ant 2018-05-08 15:31:49 UTC
REVIEW: https://review.gluster.org/19985 (Revert \"gfapi: return pre/post attributes at callback for glfs api\") posted (#1) for review on release-4.1 by Shyamsundar Ranganathan

Comment 5 Worker Ant 2018-05-08 15:32:44 UTC
REVIEW: https://review.gluster.org/19986 (Revert \"gfapi: return pre/post attributes from glfs_ftruncate\") posted (#1) for review on release-4.1 by Shyamsundar Ranganathan

Comment 6 Worker Ant 2018-05-08 15:33:40 UTC
REVIEW: https://review.gluster.org/19987 (Revert \"gfapi: return pre/post attributes from glfs_fsync/fdatasync\") posted (#1) for review on release-4.1 by Shyamsundar Ranganathan

Comment 7 Worker Ant 2018-05-08 15:34:36 UTC
REVIEW: https://review.gluster.org/19988 (Revert \"gfapi: return pre/post attributes from glfs_pread/pwrite\") posted (#1) for review on release-4.1 by Shyamsundar Ranganathan

Comment 8 Worker Ant 2018-05-09 13:31:18 UTC
COMMIT: https://review.gluster.org/19985 committed in release-4.1 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- Revert "gfapi: return pre/post attributes at callback for glfs api"

This reverts commit 384562b294e9a7847403961e878a4daa0fff33eb.

This is being reverted as the API signatures should adapt to a
statx like structure, and also all APIs that need to return
pre/post attrs are not complete.

As a result, instead of fixing up part of the APIs and then
refixing the same in a later release, removing these set of
fixes from the branch.

Updates: bz#1575386
Change-Id: Ia071797bec1e2ac085818e3909771f9ddeac6676

Comment 9 Worker Ant 2018-05-09 13:31:37 UTC
COMMIT: https://review.gluster.org/19986 committed in release-4.1 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- Revert "gfapi: return pre/post attributes from glfs_ftruncate"

This reverts commit 248152767b0599986bbb6bb35fc27197f6be6964.

This is being reverted as the API signatures should adapt to a
statx like structure, and also all APIs that need to return
pre/post attrs are not complete.

As a result, instead of fixing up part of the APIs and then
refixing the same in a later release, removing these set of
fixes from the branch.

Additionally fixed up cloudsync.c code that was using the new
syncop signature.

Updates: bz#1575386
Change-Id: Idb59d20666c0d7b0c83e7fdc31dd68b8c7db9550

Comment 10 Worker Ant 2018-05-09 13:31:56 UTC
COMMIT: https://review.gluster.org/19987 committed in release-4.1 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- Revert "gfapi: return pre/post attributes from glfs_fsync/fdatasync"

This reverts commit 09943beb499617212f2985ca8ea9ecd1ed1b470e.

This is being reverted as the API signatures should adapt to a
statx like structure, and also all APIs that need to return
pre/post attrs are not complete.

As a result, instead of fixing up part of the APIs and then
refixing the same in a later release, removing these set of
fixes from the branch.

Updates: bz#1575386
Change-Id: I3e0803c114dc6b9126d8a90f43812bca501e6338

Comment 11 Worker Ant 2018-05-09 13:32:16 UTC
COMMIT: https://review.gluster.org/19988 committed in release-4.1 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- Revert "gfapi: return pre/post attributes from glfs_pread/pwrite"

This reverts commit d01f7244e9d9f7e3ef84e0ba7b48ef1b1b09d809.

This is being reverted as the API signatures should adapt to a
statx like structure, and also all APIs that need to return
pre/post attrs are not complete.

As a result, instead of fixing up part of the APIs and then
refixing the same in a later release, removing these set of
fixes from the branch

Additionally fixed up posix-entry-ops.c which was using the
new syncop signature

Updates: bz#1575386
Change-Id: I35222dadc4a2e97010bc1e6b97b6f83583c311f6

Comment 12 Worker Ant 2018-05-09 17:02:34 UTC
REVIEW: https://review.gluster.org/19995 (doc: Initial release notes for 4.1.0) posted (#1) for review on release-4.1 by Shyamsundar Ranganathan

Comment 13 Worker Ant 2018-05-09 17:33:42 UTC
COMMIT: https://review.gluster.org/19995 committed in release-4.1 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- doc: Initial release notes for 4.1.0

Change-Id: I934d05ff32431787086d4ec4ddb45abb131d44f6
Updates: bz#1575386
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 14 Worker Ant 2018-05-09 17:42:00 UTC
COMMIT: https://review.gluster.org/19975 committed in release-4.1 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- core: remove experimental xlators and associated tests

experimental xlators removed from 4.1

Signed-off-by: ShyamsundarR <srangana@redhat.com>
Change-Id: I34419ce22ca09b7626b8f9382c377a614fd9fed8
Updates: bz#1575386

Comment 15 Worker Ant 2018-05-25 14:15:23 UTC
REVIEW: https://review.gluster.org/20089 (doc: Updated 4.1.0 release notes for smb.conf changes) posted (#1) for review on release-4.1 by Shyamsundar Ranganathan

Comment 16 Worker Ant 2018-05-29 14:39:10 UTC
COMMIT: https://review.gluster.org/20089 committed in release-4.1 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- doc: Updated 4.1.0 release notes for smb.conf changes

Updates: bz#1575386
Change-Id: I7a60b06bb57efdecbb5209ab4f98e858c8c39c77
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 17 Worker Ant 2018-05-31 16:11:56 UTC
REVIEW: https://review.gluster.org/20113 (doc: GD2 release notes for 4.1.0) posted (#1) for review on release-4.1 by Kaushal M

Comment 18 Worker Ant 2018-05-31 16:50:16 UTC
COMMIT: https://review.gluster.org/20113 committed in release-4.1 by "Kaushal M" <kaushal@redhat.com> with a commit message- doc: GD2 release notes for 4.1.0

Change-Id: Iaa32b252b84ccd95e78360130da3e8f6cbc2e7fb
updates: bz#1575386
Signed-off-by: Kaushal M <kaushal@redhat.com>

Comment 19 Worker Ant 2018-06-12 14:52:49 UTC
REVIEW: https://review.gluster.org/20247 (doc: Updated final release notes for 4.1.0) posted (#1) for review on release-4.1 by Shyamsundar Ranganathan

Comment 20 Worker Ant 2018-06-12 15:02:31 UTC
COMMIT: https://review.gluster.org/20247 committed in release-4.1 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- doc: Updated final release notes for 4.1.0

Fixes: bz#1575386

Change-Id: Iad79e16d76a55a2c3fc46629f79fec677bad597f
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 21 Shyamsundar 2018-06-20 18:06:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.