Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1575398 - [Ganesha] Lots of "NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce" messages were observed in ganesha.log while deleting files from multi client
Summary: [Ganesha] Lots of "NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NF...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nfs-ganesha
Version: rhgs-3.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: RHGS 3.4.0
Assignee: Frank Filz
QA Contact: Manisha Saini
URL:
Whiteboard:
Depends On:
Blocks: 1503137
TreeView+ depends on / blocked
 
Reported: 2018-05-06 15:01 UTC by Manisha Saini
Modified: 2018-11-09 13:55 UTC (History)
10 users (show)

Fixed In Version: nfs-ganesha-2.5.5-7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 06:55:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2610 0 None None None 2018-09-04 06:56:53 UTC

Description Manisha Saini 2018-05-06 15:01:53 UTC
Description of problem:

Lots of "NFSv3 attribute: missing 1dfce" messages were observed in ganesha.log while deleting files from 2 clients (rm -rf *) at the same time
--------
06/05/2018 09:50:11 : epoch 10430000 : dhcp37-121.lab.eng.blr.redhat.com : ganesha.nfsd-8788[work-247] nfs3_FSALattr_To_Fattr :NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce
06/05/2018 09:50:13 : epoch 10430000 : dhcp37-121.lab.eng.blr.redhat.com : ganesha.nfsd-8788[work-21] nfs3_FSALattr_To_Fattr :NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce

------


Version-Release number of selected component (if applicable):

# rpm -qa | grep ganesha
nfs-ganesha-gluster-2.5.5-6.el7rhgs.x86_64
nfs-ganesha-debuginfo-2.5.5-6.el7rhgs.x86_64
nfs-ganesha-2.5.5-6.el7rhgs.x86_64
glusterfs-ganesha-3.12.2-8.el7rhgs.x86_64



How reproducible:
3/3

Steps to Reproduce:
1.Create 4 node ganesha cluster
2.Create Distributed-Replicate 4*3 volume and export the volume via ganesha
3.Start creating files on mount point from 2 clients (v3)
4.perform rm -rf * from both the mount points

Actual results:

Continuous attribute missing messages were observed in ganesha.log

-----------------------------
# tailf /var/log/ganesha/ganesha.log
06/05/2018 09:51:41 : epoch 10430000 : dhcp37-121.lab.eng.blr.redhat.com : ganesha.nfsd-8788[work-5] nfs3_FSALattr_To_Fattr :NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce
06/05/2018 09:51:43 : epoch 10430000 : dhcp37-121.lab.eng.blr.redhat.com : ganesha.nfsd-8788[work-92] nfs3_FSALattr_To_Fattr :NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce
06/05/2018 09:51:45 : epoch 10430000 : dhcp37-121.lab.eng.blr.redhat.com : ganesha.nfsd-8788[work-232] nfs3_FSALattr_To_Fattr :NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce
06/05/2018 09:51:48 : epoch 10430000 : dhcp37-121.lab.eng.blr.redhat.com : ganesha.nfsd-8788[work-211] nfs3_FSALattr_To_Fattr :NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce
06/05/2018 09:51:52 : epoch 10430000 : dhcp37-121.lab.eng.blr.redhat.com : ganesha.nfsd-8788[work-105] nfs3_FSALattr_To_Fattr :NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce
06/05/2018 09:51:54 : epoch 10430000 : dhcp37-121.lab.eng.blr.redhat.com : ganesha.nfsd-8788[work-32] nfs3_FSALattr_To_Fattr :NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce
06/05/2018 09:52:08 : epoch 10430000 : dhcp37-121.lab.eng.blr.redhat.com : ganesha.nfsd-8788[work-5] nfs3_FSALattr_To_Fattr :NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce
06/05/2018 09:52:11 : epoch 10430000 : dhcp37-121.lab.eng.blr.redhat.com : ganesha.nfsd-8788[work-158] nfs3_FSALattr_To_Fattr :NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce
06/05/2018 09:52:16 : epoch 10430000 : dhcp37-121.lab.eng.blr.redhat.com : ganesha.nfsd-8788[work-9] nfs3_FSALattr_To_Fattr :NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce
06/05/2018 09:52:16 : epoch 10430000 : dhcp37-121.lab.eng.blr.redhat.com : ganesha.nfsd-8788[work-173] nfs3_FSALattr_To_Fattr :NFS3 :CRIT :Likely bug: FSAL did not fill in a standard NFSv3 attribute: missing 1dfce
---------------------

Expected results:
No such missing attribute messages should be logged in ganesha.log


Additional info:

Comment 11 errata-xmlrpc 2018-09-04 06:55:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2610


Note You need to log in before you can comment on or make changes to this bug.