Bug 1575404 - System crashes on high memory usage
Summary: System crashes on high memory usage
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-06 16:01 UTC by SlayerProof32
Modified: 2018-07-23 17:21 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-23 17:21:55 UTC
Type: Bug


Attachments (Terms of Use)

Description SlayerProof32 2018-05-06 16:01:26 UTC
Description of problem:
When opening a lot of tabs in Firefox, the system ram usage goes up as expected, but when available ram gets to 0, the system freezes up, and sometimes doesn't unfreeze


Version-Release number of selected component (if applicable):
Fedora 27
Fedora 28
Opensuse leap 15
Ubuntu 17.10
Ubuntu 18.04
Manjaro Linux latest version

How reproducible:
Always 

Steps to Reproduce:
1.Boot up your system
2.Open up a site that requires a lot of ram (ex) google docs
3.Duplicate the tab a bunch of tabs
4.Wait till your ram is maxed out
5. System becomes slow, unresponsive, or completely frozen so much sometimes that the only way get it working again is to hold down the power button

Actual results:
System freezes, or is slow at high ram usage
Swap space is barely used
CPU load average spikes to sometimes 1000%

Expected results:
CPU load average stays constant
Swap is used a lot more
OOM killer kills more processes to help free ram
System does not freeze and I can continue working

Additional info:
Tested 
Intel E6400 with 3072mB 533MHz ddr2 ram with3gb swap . Gnome 3.26 and 3.28 kernel 4.12 and 4.15 on ubuntu 18.04, Opensuse leap 15 and fedora 28
Intel i5-520M with 4096MB ram. 4gb swap. Gnome 3.28 running Manjaro Linux 

Many users have reported this issue since 2007. Fix has not yet been provided other than to edit the /etc/sysctl conf file

Comment 1 SlayerProof32 2018-05-10 03:21:37 UTC
After the latest updates from DNF Update, this issue no longer exists. Closed

Comment 2 SlayerProof32 2018-06-06 02:06:04 UTC
Never mind, the issue still exists.

Comment 3 Justin M. Forbes 2018-07-23 15:02:08 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.

Fedora 28 has now been rebased to 4.17.7-200.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 4 SlayerProof32 2018-07-23 17:21:55 UTC
This does not occur anymore. Swap is a lot better now. I can’t get the system to freeze anymore.


Note You need to log in before you can comment on or make changes to this bug.