Bug 1575451 - Openshift-web-console pods shows previous OCP version after upgrading from 3.9.14 to 3.9.25
Summary: Openshift-web-console pods shows previous OCP version after upgrading from 3....
Keywords:
Status: CLOSED DUPLICATE of bug 1574682
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.9.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 00:56 UTC by Jatan Malde
Modified: 2018-05-07 14:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 14:11:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jatan Malde 2018-05-07 00:56:51 UTC
Description of problem:

Openshift-web-console-pods after upgrading the cluster from  3.9.14 to 3.9.25 shows v3.9.14 as the OCP version which is incorrect.

OpenShift Master:
    v3.9.25 
Kubernetes Master:
    v1.9.1+a0ce1bc657 
OpenShift Web Console:
    v3.9.14 

oc describe pod webconsole-c9cf7f469-9lt72|grep Image:
    Image:         registry.access.redhat.com/openshift3/ose-web-console:v3.9.25

But inside the container the RPM looks to be still 3.9.14
$ oc rsh webconsole-c9cf7f469-9lt72 rpm -q atomic-openshift-web-console
atomic-openshift-web-console-3.9.14-1.git.229.04c20c2.el7.x86_64

Version-Release number of selected component (if applicable):

OpenShift Master:
    v3.9.25

How reproducible:

Steps to Reproduce:
1.Install a OCP cluster of version v3.9.25 or upgrade the cluster from OCP v3.9.14 to v3.9.25 
2. Get the web-console pods up and running,
3. Run the command 'oc rsh webconsole-c9cf7f469-9lt72 rpm -q atomic-openshift-web-console'


Actual results:
Openshift web-console pods shows the wrong version.

Expected results:
Openshift web-console pods should show the new and updated version of the cluster.

Additional info:

From the container catalog it seems that v3.9.25-1 and v3.9.25 are both using 'atomic-openshift-web-console-3.9.14-1.git.229.04c20c2.el7.x86_64' as the web-console package.

https://access.redhat.com/containers/?tab=package-list#/registry.access.redhat.com/openshift3/ose-web-console/images/v3.9.25-1

Comment 1 Seth Jennings 2018-05-07 14:11:30 UTC
confirmed

$ docker run registry.access.redhat.com/openshift3/ose-web-console:v3.9.25 rpm -q atomic-openshift-web-console
atomic-openshift-web-console-3.9.14-1.git.229.04c20c2.el7.x86_64

*** This bug has been marked as a duplicate of bug 1574682 ***


Note You need to log in before you can comment on or make changes to this bug.