Bug 1575508 - [install]openshift-ansible do not create bundlebindings and jobstate CRD for asb
Summary: [install]openshift-ansible do not create bundlebindings and jobstate CRD for asb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.10.0
Assignee: Shawn Hurley
QA Contact: Zihan Tang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 07:12 UTC by Zihan Tang
Modified: 2018-07-30 19:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:14:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:14:59 UTC

Description Zihan Tang 2018-05-07 07:12:10 UTC
Description of problem:
When install asb using openshift ansible, it do not create bundlebindings and jobstate CRD for asb 

Version-Release number of selected component (if applicable):
openshift-ansible : v3.10.0-0.35.0.0
asb: v3.10.0-0.35.0.0 , v1.2.10

How reproducible:
always

Steps to Reproduce:
1. provision asb using openshift-ansible 


Actual results:
When creating crd resource , only create bundleinstances and bundles.

TASK [ansible_service_broker : Create custom resource definitions for asb] *****
Monday 07 May 2018  06:34:36 +0000 (0:00:00.033)       0:01:03.957 ************ 
skipping: [host-8-245-114.host.centralci.eng.rdu2.redhat.com] => (item=/usr/share/ansible/openshift-ansible/roles/ansible_service_broker/files/bundleinstances.automationbroker.io.yaml) 
skipping: [host-8-245-114.host.centralci.eng.rdu2.redhat.com] => (item=/usr/share/ansible/openshift-ansible/roles/ansible_service_broker/files/bundles.automationbroker.io.yaml) 

[root@host-172-16-120-56 tmp]# oc get crd
NAME                                  AGE
bundleinstances.automationbroker.io   28m
bundles.automationbroker.io           28m


Expected results:
will create all 4 kind CRDs  for asb.

Additional info:

Comment 1 Zihan Tang 2018-05-07 07:23:05 UTC
binding is the basic functionality , it blocks critical cases, so add TestBlocker tag.

Comment 2 Zihan Tang 2018-05-07 08:18:40 UTC
we can manually create bundle crd from PR https://github.com/openshift/openshift-ansible/pull/8178 as workaround. 

oc create -f https://raw.githubusercontent.com/shawn-hurley/openshift-ansible/7cb22b6ccbfddf9fbed49f736ab54e9cb188a1a5/roles/ansible_service_broker/files/bundlebindings.automationbroker.io

is the 'jobstates' migrated into 'bundleinstances' and 'bundlebindings' as designed ?

Comment 3 Shawn Hurley 2018-05-07 12:10:55 UTC
PR posted here: https://github.com/openshift/openshift-ansible/pull/8272

Comment 5 Zihan Tang 2018-05-11 09:58:35 UTC
The image is ready, change it to ON_QA

Comment 6 Zihan Tang 2018-05-11 10:00:08 UTC
Verified.
openshift-ansible version: v3.10.0-0.39.0

Comment 8 errata-xmlrpc 2018-07-30 19:14:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.