Bug 1575512 - [RFE OSP 16.1][Test only] Multicast support with OVN and OSP
Summary: [RFE OSP 16.1][Test only] Multicast support with OVN and OSP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 16.0 (Train)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z4
: 16.1 (Train on RHEL 8.2)
Assignee: ffernand
QA Contact: Roman Safronov
URL:
Whiteboard:
: 1791787 1886103 (view as bug list)
Depends On: 1886314 1898052
Blocks: 1791815 1922507
TreeView+ depends on / blocked
 
Reported: 2018-05-07 07:32 UTC by Pablo Iranzo Gómez
Modified: 2021-03-17 15:37 UTC (History)
24 users (show)

Fixed In Version: python-networking-ovn-7.3.1-1.20201114024050.el8ost
Doc Type: Enhancement
Doc Text:
With this enhancement, you can control multicast over the external networks and avoid cluster autoforming over external networks instead of only the internal networks.
Clone Of:
Environment:
Last Closed: 2021-03-17 15:30:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 705237 0 None MERGED [OVN] Add IGMP snooping support 2021-02-15 16:26:46 UTC
Red Hat Product Errata RHBA-2021:0817 0 None None None 2021-03-17 15:37:48 UTC

Description Pablo Iranzo Gómez 2018-05-07 07:32:11 UTC
Description of problem:

Customer is using JBoss cluster autodetection and they require to control multicast over the external networks in order to avoid cluster autoforming over external networks instead of just the internals


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Daniel Alvarez Sanchez 2020-03-23 13:55:27 UTC
*** Bug 1791787 has been marked as a duplicate of this bug. ***

Comment 10 Scott Lewis 2020-04-19 19:06:39 UTC
Removing Target Milestone; please replan

Comment 18 Lon Hohberger 2020-07-29 10:46:42 UTC
According to our records, this should be resolved by python-networking-ovn-7.2.1-0.20200611111150.18fabca.el8ost.  This build is available now.

Comment 26 Lucas Alvares Gomes 2020-10-13 13:28:23 UTC
*** Bug 1886103 has been marked as a duplicate of this bug. ***

Comment 36 Roman Safronov 2021-01-22 11:51:50 UTC
Was verified on puddle RHOS-16.1-RHEL-8-20210120.n.1 with python3-networking-ovn-7.3.1-1.20201114024050.el8ost.noarch

Verified that igmp snooping works properly on external and internal networks, no flooding to all ports of logical switch, only to the ports that have subscribed clients behind them.

Comment 37 Roman Safronov 2021-01-22 12:01:07 UTC
Addition to the previous comment. For proper work an external igmp querier is required. Otherwise clients will not remain subscribed after idle timeout, 300 seconds by default. For internal networks the external querier can not be used. There is an option to enable an internal querier in OVN, see [1], but it is still not officially supported.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1791815#c2

Comment 49 errata-xmlrpc 2021-03-17 15:30:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenStack Platform 16.1.4 director bug fix advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0817

Comment 50 errata-xmlrpc 2021-03-17 15:37:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenStack Platform 16.1.4 director bug fix advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0817


Note You need to log in before you can comment on or make changes to this bug.