Bug 1575516 - salt is violating Spec Maintenance and Canonicity
Summary: salt is violating Spec Maintenance and Canonicity
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: salt
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: David Murphy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1599925 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 07:43 UTC by Igor Gnatenko
Modified: 2018-07-11 16:47 UTC (History)
5 users (show)

Fixed In Version: Salt 2018.3.0-2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 14:48:36 UTC
Type: Bug


Attachments (Terms of Use)

Comment 1 David Murphy 2018-05-07 16:07:12 UTC
Apologies for that cut and paste error

I have updated the current salt.spec for Rawhide, for version 2018.3.0 to correct the changelog, git diff below.  Is there any other change that I may have overlooked  and need to correct.  The other change in the Changelog, removal of Ch3ll.com, was a correction which correctly should have read saltstack.com.

dmurphy18@fedora-min:~/check_Rawhide/salt$ git diff --cached salt.spec
diff --git a/salt.spec b/salt.spec
index 8d1979d..e866284 100644
--- a/salt.spec
+++ b/salt.spec
@@ -42,7 +42,7 @@
 
 Name: salt
 Version: 2018.3.0%{?__rc_ver}
-Release: 1%{?dist}
+Release: 2%{?dist}
 Summary: A parallel remote execution system
 
 Group:   System Environment/Daemons
@@ -626,6 +626,9 @@ rm -rf %{buildroot}
 %endif
 
 %changelog
+* mon May 07 2018 SaltStack Packaging Team <packaging@saltstack.com> - 2018.3.0-2
+- Update to feature release 2018.3.0-2
+
 * Fri Mar 30 2018 SaltStack Packaging Team <packaging@saltstack.com> - 2018.3.0-1
 - Update to feature release 2018.3.0-1
 
@@ -636,6 +639,9 @@ rm -rf %{buildroot}
 - Update to feature release 2017.7.4-1
 - Limit to Tornado use to between versions 4.2.1 and less than 5.0
 
+* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2017.7.3-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
 * Tue Jan 30 2018 SaltStack Packaging Team <packaging@saltstack.com> - 2017.7.3-1
 - Update to feature release 2017.7.3-1
 

Thanks for bringing this to SaltStack's attention.

Comment 2 Igor Gnatenko 2018-05-07 16:57:27 UTC
yes, removal of `BuildRoot` tag and `%clean` section.

Comment 3 David Murphy 2018-05-07 17:43:13 UTC
Fixed in spec file for Salt 2018.3.0-2

Comment 4 David Murphy 2018-07-11 16:47:21 UTC
*** Bug 1599925 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.