Bug 1575531 - [Docs][Metrics Install] Corrections for Metrics Installation Guide
Summary: [Docs][Metrics Install] Corrections for Metrics Installation Guide
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.2.3
Hardware: All
OS: All
high
high
Target Milestone: ovirt-4.3.1
: 4.3.0
Assignee: Avital Pinnick
QA Contact: rhev-docs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1665562
TreeView+ depends on / blocked
 
Reported: 2018-05-07 08:17 UTC by Lukas Svaty
Modified: 2019-05-07 12:44 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-14 14:17:38 UTC
oVirt Team: Metrics
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Lukas Svaty 2018-05-07 08:31:03 UTC
Will consider this as tracker as there are more issues with this documentation.

- paragraph 1.1 
    - OpenShift - requirement should be OCP 3.9 and RHEL 7.5
- paragraph 1.2 - Metrics Store Machine Prerequisites - Ste2.
    - arent we missing openshift.FQDN for Openshift??
- paragraph 1.2 - Manager Machine Prerequisites
    - we already support timezone with trailing Z for UTC
- paragraph 2.1 table 2.1 -
    - ovirt_env_name - default value is set to yes and no default values is stated
- paragraph 3.6 - 3.6. Configuring Persistent Storage for Elasticsearch - Configuring Persistent Storage for Elasticsearch - All the steps
    - proper pathh should be /mounted_storage_directory/elasticsearch, where by default mounted_storage_directory is set to /var/lib, therefore in Steps 3+ it should be /mounted_storage_directory/elasticsearch instead of /mounted_storage_directory/lib/elasticsearch
- paragraph 3.8 - Running Ansible - step3
    - we need to run 3 playbooks in OCP 3.9
        - "/usr/share/ansible/openshift-ansible/playbooks/prerequisites.yml"
        - "/usr/share/ansible/openshift-ansible/playbooks/openshift-node/network_manager.yml"
        - "/usr/share/ansible/openshift-ansible/playbooks/deploy_cluster.yml"
- paragraph 3.10 - Verifying the OpenShift Aggregated Logging Installation - Verifying the OpenShift Aggregated Logging Installation - Step 7 -  Ensure that the value of HOST/PORT is correct. 
    - instruction unclear what should be the host and port

Comment 2 Pavol Brilla 2018-05-07 09:10:26 UTC
adding few more which I found in same document during today installation:

- paragraph 1 
    - we have already Ansible 2.5

- paragraph 3.6
    - as OpenShift requirement changed to 3.9 this paragraph should take it into account as well
- paragraph 3.7
    - packages: openshift-ansible-callback-plugins, openshift-ansible-filter-plugins,openshift-ansible-lookup-plugins should be removed as from Ansible 2.5 they dont exists ( they are not needed as well )
- paragraph 3.8 - Running Ansible
    - file to be used with playbook - ansible-inventory-ocp-39-aio

Comment 3 Pavol Brilla 2018-05-07 09:58:18 UTC
 - paragraph 3.9
    - oadm policy will get us INFO message which we should implement in doc: DEPRECATED: The 'oadm' command is deprecated, please use 'oc adm' instead.

Comment 6 Sandro Bonazzola 2019-01-28 09:39:43 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 8 Emma Heftman 2019-01-29 07:34:02 UTC
Hi Ivana,

Can you please let me know whether you think any of the above comments are relevant for 4.3?

1. paragraph 1.2 - Metrics Store Machine Prerequisites - Ste2.
    - arent we missing openshift.FQDN for Openshift??


2. paragraph 1.2 - Manager Machine Prerequisites
    - we already support timezone with trailing Z for UTC

3. paragraph 3.10 - Verifying the OpenShift Aggregated Logging Installation - Verifying the OpenShift Aggregated Logging Installation - Step 7 -  Ensure that the value of HOST/PORT is correct. 
    - instruction unclear what should be the host and port

Ivana, this is more a question about how to fix what is written.



Lukas, all other comments have been covered by the latest installation doc that we are working on, and that you can view here:
 
http://file.tlv.redhat.com/~eheftman/bz1598423/html-single/#System_Requirements

Comment 9 Ivana Saranova 2019-01-30 12:41:06 UTC
Hi Emma, 

yes, the openshift.FDQN should be there, but as of now, I can't tell which of the openshift prefixes are supposed to be used, because there are a lot. I'm not sure about the rest, Shirly might know more so I'll tag her here.

Also there is a problem in the current documentation in the chapter 3.8, all logging should be openshift-logging, so the commands in that section should look like this:

    oc project openshift-logging
    oadm policy add-scc-to-user hostmount-anyuid \
             system:serviceaccount:logging:aggregated-logging-elasticsearch

    oc rollout cancel $( oc get -n openshift-logging dc -l component=es -o name )
    oc rollout latest $( oc get -n openshift-logging dc -l component=es -o name )
    oc rollout status -w $( oc get -n openshift-logging dc -l component=es -o name )

Comment 10 Emma Heftman 2019-01-30 12:56:48 UTC
(In reply to Ivana Saranova from comment #9)
> Hi Emma, 
> 
> yes, the openshift.FDQN should be there, but as of now, I can't tell which
> of the openshift prefixes are supposed to be used, because there are a lot.
> I'm not sure about the rest, Shirly might know more so I'll tag her here.
> 
> Also there is a problem in the current documentation in the chapter 3.8, all
> logging should be openshift-logging, so the commands in that section should
> look like this:
> 
>     oc project openshift-logging
>     oadm policy add-scc-to-user hostmount-anyuid \
>              system:serviceaccount:logging:aggregated-logging-elasticsearch
> 
>     oc rollout cancel $( oc get -n openshift-logging dc -l component=es -o
> name )
>     oc rollout latest $( oc get -n openshift-logging dc -l component=es -o
> name )
>     oc rollout status -w $( oc get -n openshift-logging dc -l component=es
> -o name )

I've added openshift_FQDN to the docs, as well as the change to openshift-logging.
I don't want to use this bug to track any new comments tho. 

So, we still need the prerequisites and to understand what the issue is with the verification.

Shirly, 

can you please clarify whether we can remove this sentence:

"Ensure that the time stamp in the */var/log/ovirt-engine/engine.log* file contains a UTC offset suffix, rather than a letter such as Z or A. For example:
2018-03-27 13:35:06,720+01"


As Lukas says that it is supported.

Also, Lukas asked what should the value of HOST/PORT be when we are verifying the installation.

Comment 11 Emma Heftman 2019-02-14 14:17:38 UTC
All issues have now been resolved. They have either been fixed or removed from the new installation altogether and are part of this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1598423


Note You need to log in before you can comment on or make changes to this bug.