Bug 1575542 - date/time selectors in volume snapshot's schedule doesn't work
Summary: date/time selectors in volume snapshot's schedule doesn't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-4.4.1
: 4.4.1.3
Assignee: Ritesh Chikatwar
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 09:04 UTC by Lucie Leistnerova
Modified: 2020-08-31 11:20 UTC (History)
9 users (show)

Fixed In Version: ovirt-engine-4.4.1.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-05 06:24:51 UTC
oVirt Team: Gluster
pm-rhel: ovirt-4.4?
pm-rhel: ovirt-4.5?
sasundar: planning_ack?
godas: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)
snapshot schedule video (453.85 KB, application/octet-stream)
2018-05-07 09:04 UTC, Lucie Leistnerova
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 109531 0 master MERGED webadmin: ensure DateTimePicker consumes mouse events 2020-08-31 11:19:59 UTC

Description Lucie Leistnerova 2018-05-07 09:04:34 UTC
Created attachment 1432535 [details]
snapshot schedule video

Description of problem:
When I want to schedule creating snapshots for gluster volume, popup caledar/time selector doesn't do anything after clicking on date/time.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.3.5-0.1.el7.noarch

How reproducible: always


Steps to Reproduce:
1. add gluster host to engine, create gluster volume with some bricks and start it
2. select the volume and click on Snapshot -> New
3. click on date text input (e.g. Start Schedule by)
4. calendar appears, click on same day

Actual results: nothing happens, see attachment


Expected results: selected date/time appears in text input and calendar/time selector disappears


Additional info:
Tested in FF 59.0.2 and Google Chrome 65.0
No error in engine log, ui log, console.

Comment 1 Sandro Bonazzola 2019-01-28 09:42:05 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 2 Sahina Bose 2019-01-30 11:49:46 UTC
Kaustav, can you take a look?

Comment 3 rszwajko 2020-03-20 15:16:14 UTC
I can confirm the problem is still there in  4.4.

Workarounds:
1. edit date using keyboard and click "enter"
2. use up/down/left/righ keys to move selection when the calendar popup is opened

Cause: for some reason the callbacks are not being triggered on mouse click.

This widget is used only in gluster snapshot dialog - perhaps we could replace it with some working widget?
If not, then perhaps it classifies as UI infrastructure bug - date time picker seems basic widget to me?

Comment 4 Ritesh Chikatwar 2020-03-30 11:56:43 UTC
Sharon,

I tried debugging this issue not able to make the changes require to make it work.

As Radoslaw said there is a issue for callback not happening for mouse click events.

Any input/suggestion's to make it work. If not can i move this big UX team as it's UI infrastructure bug

Comment 5 Gobinda Das 2020-06-09 09:42:57 UTC
Targeting this to 4.4.1 as the patch is merged and it's a urgent one.So it's better to include in 4.4.1.

Comment 6 SATHEESARAN 2020-07-14 05:38:23 UTC
Tested with RHV Manager Version 4.4.1.8-0.7.el8ev 

1. Selected the volume
2. Created new gluster volume snapshot schedule by clicking today
3. Selected the GMT time for the schedule

At the right scheduled time, gluster volume snapshot is taken

Comment 7 Sandro Bonazzola 2020-08-05 06:24:51 UTC
This bugzilla is included in oVirt 4.4.1 release, published on July 8th 2020.

Since the problem described in this bug report should be resolved in oVirt 4.4.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.