Bug 1575552 - entering volume's detail shows UI error
Summary: entering volume's detail shows UI error
Keywords:
Status: CLOSED DUPLICATE of bug 1574451
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 09:42 UTC by Lucie Leistnerova
Modified: 2018-05-07 10:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 10:21:29 UTC
oVirt Team: Gluster


Attachments (Terms of Use)
volume detail (73.73 KB, image/png)
2018-05-07 09:42 UTC, Lucie Leistnerova
no flags Details

Description Lucie Leistnerova 2018-05-07 09:42:11 UTC
Created attachment 1432544 [details]
volume detail

Description of problem:
In gluster volumes' detail appears repeatedly UI error:

Uncaught exception occurred. Please try reloading the page. Details: (TypeError) : b.b.b is null
Please have your administrator check the UI logs

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.3.5-0.1.el7.noarch

How reproducible: always on one specific volume


Steps to Reproduce:
1. add gluster host to engine, prepare LV with thin provisioning on the host
2. create volume in engine from this LV
3. go to volume's detail

Actual results: UI error appears


Expected results: no UI error


Additional info:
The only differences in this volume is, that it's gluster volume with thin provisioning. And no matter if it's Up or Down.
And strange is the '?' in grid column 'Space Used' and in detail:
Capacity:
19.97 GiB total, 65.26 MiB used, 19.91 GiB free

ui.log

2018-05-07 11:29:27,201+02 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-7) [] Permutation name: F6D22492B8851B03F88C9AD748615BD4
2018-05-07 11:29:27,201+02 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-7) [] Uncaught exception: com.google.gwt.core.client.JavaScriptException: (TypeError) : b.b.b is null
        at org.ovirt.engine.ui.webadmin.section.main.view.tab.gluster.SubTabVolumeGeneralView.$setMainSelectedItem(SubTabVolumeGeneralView.java:141)
        at org.ovirt.engine.ui.webadmin.section.main.view.tab.gluster.SubTabVolumeGeneralView.setMainSelectedItem(SubTabVolumeGeneralView.java:141)
        at org.ovirt.engine.ui.common.presenter.AbstractSubTabPresenter.$onDetailModelEntityChange(AbstractSubTabPresenter.java:358)
        at org.ovirt.engine.ui.common.presenter.AbstractSubTabPresenter.$lambda$6(AbstractSubTabPresenter.java:333)
        at org.ovirt.engine.ui.common.presenter.AbstractSubTabPresenter$lambda$6$Type.eventRaised(AbstractSubTabPresenter.java:333)
        at org.ovirt.engine.ui.uicompat.Event.$raise(Event.java:99)
        at org.ovirt.engine.ui.uicommonweb.models.EntityModel.$setEntity(EntityModel.java:35)
        at org.ovirt.engine.ui.uicommonweb.models.EntityModel.setEntity(EntityModel.java:35)
        at org.ovirt.engine.ui.uicommonweb.models.ListWithDetailsModel.$onSelectedItemChanged(ListWithDetailsModel.java:89)
        at org.ovirt.engine.ui.uicommonweb.models.volumes.VolumeListModel.onSelectedItemChanged(VolumeListModel.java:451)
        at org.ovirt.engine.ui.uicommonweb.models.SearchableListModel.$setItems(SearchableListModel.java:707)
        at org.ovirt.engine.ui.uicommonweb.models.SearchableListModel.setItems(SearchableListModel.java:707)
        at org.ovirt.engine.ui.uicommonweb.models.SearchableListModel$SetItemsAsyncQuery$1.$onSuccess(SearchableListModel.java:870)
        at org.ovirt.engine.ui.uicommonweb.models.SearchableListModel$SetItemsAsyncQuery$1.onSuccess(SearchableListModel.java:870)
        at org.ovirt.engine.ui.frontend.Frontend$1.$onSuccess(Frontend.java:227) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.Frontend$1.onSuccess(Frontend.java:227) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.OperationProcessor$1.$onSuccess(OperationProcessor.java:133) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.OperationProcessor$1.onSuccess(OperationProcessor.java:133) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.GWTRPCCommunicationProvider$5$1.$onSuccess(GWTRPCCommunicationProvider.java:270) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.GWTRPCCommunicationProvider$5$1.onSuccess(GWTRPCCommunicationProvider.java:270) [frontend.jar:]
        at com.google.gwt.user.client.rpc.impl.RequestCallbackAdapter.onResponseReceived(RequestCallbackAdapter.java:198) [gwt-servlet.jar:]
        at com.google.gwt.http.client.Request.$fireOnResponseReceived(Request.java:233) [gwt-servlet.jar:]
        at com.google.gwt.http.client.RequestBuilder$1.onReadyStateChange(RequestBuilder.java:409) [gwt-servlet.jar:]
        at Unknown.onreadystatechange<(https://engine/ovirt-engine/webadmin/?locale=en_US#volumes)
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:236) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:275) [gwt-servlet.jar:]
        at Unknown.Ju/<(https://engine/ovirt-engine/webadmin/?locale=en_US#volumes)
        at Unknown.anonymous(Unknown)

Comment 1 Sahina Bose 2018-05-07 10:21:29 UTC

*** This bug has been marked as a duplicate of bug 1574451 ***


Note You need to log in before you can comment on or make changes to this bug.