Bug 157556 - matrox video driver corrupting display, duplicating portions of screen
matrox video driver corrupting display, duplicating portions of screen
Status: CLOSED DUPLICATE of bug 161242
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On: libvgahw
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-12 13:30 EDT by Tom Wood
Modified: 2007-11-30 17:11 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-29 16:08:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
MGA Xorg.log (39.71 KB, text/plain)
2005-06-20 04:36 EDT, Adam Pribyl
no flags Details
Xorg.0.log log file when enabling the dual heads (17.63 KB, application/octet-stream)
2005-06-20 07:34 EDT, Patrick Pichon
no flags Details
xorg.conf used to enable to dual head (4.08 KB, application/octet-stream)
2005-06-20 07:35 EDT, Patrick Pichon
no flags Details

  None (edit)
Description Tom Wood 2005-05-12 13:30:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Red Hat/1.0.3-1.4.1.centos4 Firefox/1.0.3

Description of problem:
Unlike the previous green and blue boxes around the entire display, but similar to what I saw in FC4T1, X interlaces and duplicates portions of the screen.  Upon exiting X, the display shifts, omits, and duplicates characters.  Note that booting into runlevels 2 or 3 and not starting X, the display is fine.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-30

How reproducible:
Always

Steps to Reproduce:
1. startx
2. See the strange, flickering, interlaced display.
3. Exit X
4. See the strange dropped characters, duplicates, and other shenanigans.
  

Actual Results:  Bad video

Expected Results:  Good video

Additional info:

This is probably related to the other upstream mga driver issues, but since the symptoms are different, I logged this as a separate bug report.
Comment 1 Dave Malcolm 2005-05-13 15:02:19 EDT
I'm also seeing similar problems with xorg-x11-6.8.2-30 on Rawhide.
Virtual terminals have a green border with a yellow and pink colorsceheme of
corrupted display on the main part of the display.
Logging in as a user clears up the corruption (colour scheme remains).  
Switching to X and back to the virtual terminal yields the corrupt display
again.  Typing "reset" at a virtual terminal doesn't help.
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 04)
Comment 2 Mike A. Harris 2005-05-24 12:09:30 EDT
Tom:

Try the following:

1) Make a backup of the mga_drv driver, and /usr/X11R6/lib/modules/libvgahw.a

2) If you take the mga_drv.o driver from Fedora Core 3 and test it with
   FC4, does the problem go away?

3) Now restore the mga_drv back to the FC4 one.  Now drop the libvgahw.a
   from FC3 into the modules dir, and test that out.  Does this make the
   problem go away?

4) If the problem still occurs, try using both of these modules at the
   same time and indicate if that works around the problem.


We're seeing various odd reports with matrox hardware, but also some other
hardware too, and it appears that libvgahw.a might be related to at least
some number of the problems.

Please attach your X server log file and config file also.


Dave:

Bug alias "green-border" contains the droids you're after.  ;o)
/usr/X11R6/lib/modules/libvgahw.a
Comment 3 Tom Wood 2005-06-03 16:21:37 EDT
The libvgahw.a from FC3 fixes the problem.
Comment 4 Daniel Roesen 2005-06-03 21:38:02 EDT
Having similar problems with G550 and Dell 2001FP monitor, both with VGA and DVI
(cannot even install with VGA).

Can someone send me FC3 libvgahw.a unicast via email, and I will try to replace
it via SSH and see if this fixes it for me too.
Comment 5 Dr J Austin 2005-06-04 05:32:00 EDT
Cross reference to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=153729
Comment 6 Daniel Roesen 2005-06-04 17:59:00 EDT
FC3 libvgahw.a doesn't fix it for me. Better, but not fine.

Will test FC3 mga_drv.o now.
Comment 7 Daniel Roesen 2005-06-05 16:15:39 EDT
FC3 mga_drv.o doesn't help in any way too. So FC4 will be a no-go
on my fairly "non-uncommon" G550 system.

I'm curious wether there are ANY Matrox systems out there which work
OK with FC4T3...
Comment 8 Karen Spearel 2005-06-05 20:55:50 EDT
On my Athlon 1700+ XP/Epox 8rda+ (nforce 2)/G450 (detected as G400), I had
unresponsive blank screen VTs with the bright green border.

Step 1:
Moving libvgahw.a from FC3 fixes the Virtual Terminal problem entirely...they
come up exactly as expected and operate normally with no green border.  Before I
made this change, I had unresponsive blank screen VTs with the bright green
border.  Moving the file fixed the problem but only *after* a reboot, I believe.

CTRL ALT BACKSPACE doesn't do the right thing.  It shifts you to an entirely
blank text screen where, after moving the mouse, a block cursor shows and upon
typing chars, they are echoed to the screen but have no effect.  This acts just
like C-A-F8 would where there is no tty running. C-A-F1 will take you to a
properly working VT but C-A-F7 takes you to a blank screen with no sign of X
running. 

Startx from VT1 works fine.  X comes up and the desktop is displayed as
expected. C-A-BS takes you to a blank screen with no login ability but you can
switch to another VT to login.  Seems like it is coming up on a VT that isn't
running.
 
Step 2:
Also replacing mga_drv.o allows C-A-BS to work ie you get a login prompt on :0.
 Logging in and startx works as expected.

To sum up - by replacing libvgahw.a and mga_drv.o with those files from FC3, all
outstanding problems with FC4T3 on a Matrox G450 are cleared up AFAICT here. 
Comment 9 Daniel Roesen 2005-06-06 08:22:45 EDT
OK, FWIW, replacing the xorg-* RPMs with the current FC3 ones fixed the problem
for me completely. So "something" between the FC3-updates xorg RPMs and the
FC4T3 ones (which only differ in the -N release number, not version) has changed
that
rendered (some?) Matrox stuff unusable. Looks like we need to back out some
patches and try to find the culprit...

Mike, how do you suggest we go from here?
Comment 10 Joe Ceklosky 2005-06-19 22:07:15 EDT
I also have a G550 with problems on Fedora Core 4.
I replaced xorg with the latest and greatest from Fedora Core 3 and the problems
went away.

I see this as a bug in the source code, patches for fedora core 4, or a possbile
mis-compile from gcc 4.0.

Comment 11 Adam Pribyl 2005-06-20 04:33:50 EDT
I have Matrox G200, and I am experiencing same problems with FC4 xorg 6.8.2.
Using mga video driver in Xorg yealds fine working X window system, however the
console has green border and I see nothing else there. No other possibility to
fix it than to reboot.

I tested with vesa driver. This has even worse behaviour. I have black console,
and X window does not start at all. Screen is black all the time. Computer
probably stops responding completely.
Vga driver is working, but is useless.
Comment 12 Adam Pribyl 2005-06-20 04:36:17 EDT
Created attachment 115676 [details]
MGA Xorg.log
Comment 13 Patrick Pichon 2005-06-20 07:34:40 EDT
Created attachment 115682 [details]
Xorg.0.log log file when enabling the dual heads
Comment 14 Patrick Pichon 2005-06-20 07:35:53 EDT
Created attachment 115683 [details]
xorg.conf used to enable to dual head
Comment 15 Patrick Pichon 2005-06-20 07:41:32 EDT
I'm experiencing the same issues under FC4 with an Matrox G400 card.
I have used the libvgahw.a from FC3 and sorted out the Virtual Terminal issue.
An other way was also to boot with option vga=768 !

Would be good to move the Version field from FC4test3 to FC4!

However, when I enable the dual head with the attached xorg.conf I'm freezing my
system (hang ) whatever is the libvgahw.a coming from FC4 or FC3.
Comment 16 Joe Ceklosky 2005-06-20 08:26:11 EDT
M. Harris,

Do you have any thoughts as to what appears to be wrong with the mga driver on
FC4?  

If you need someone to test, build, and install packges for changes, I can help
you out, just let me know.

My problems were fixed by using the lastest FC3 xorg package on FC4.
Comment 17 Patrick Pichon 2005-06-21 10:12:14 EDT
got interaction with matrox support, and finaly we installed the mga driver for
XFree86 4.3.0 (mga version 3.0) 

The dual head works ... 
Comment 18 Mike A. Harris 2005-06-29 16:08:00 EDT

*** This bug has been marked as a duplicate of 161242 ***

Note You need to log in before you can comment on or make changes to this bug.