Bug 1575596 - /vm/affinitylabels should return the same as /affinitylabels
Summary: /vm/affinitylabels should return the same as /affinitylabels
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: 4.2.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.4
: ---
Assignee: Ori Liel
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 12:11 UTC by Lucie Leistnerova
Modified: 2018-06-26 08:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:45:44 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 91216 master MERGED restapi: Fix Affinity Label Links 2018-05-23 11:25:27 UTC
oVirt gerrit 91535 ovirt-engine-4.2 MERGED restapi: Fix Affinity Label Links 2018-05-23 15:48:05 UTC

Description Lucie Leistnerova 2018-05-07 12:11:25 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. add affinity label to some vm
2. run for the specific vm:
curl -k -u admin@internal:123456 -H "Prefer: persistent-auth" https://engine/ovirt-engine/api/vms/<vm_id>/affinitylabels


Actual results: affinity_label without links to vms and hosts

    <affinity_label href="/ovirt-engine/api/affinitylabels/9a443202-2349-40a2-bff6-320d569aeb26" id="9a443202-2349-40a2-bff6-320d569aeb26">
        <name>test</name>
        <read_only>false</read_only>
    </affinity_label>

Expected results: the same as in main affinitylabels result

curl -k -u admin@internal:123456 -H "Prefer: persistent-auth" https://engine/ovirt-engine/api/affinitylabels

    <affinity_label href="/ovirt-engine/api/affinitylabels/9a443202-2349-40a2-bff6-320d569aeb26" id="9a443202-2349-40a2-bff6-320d569aeb26">
        <name>test</name>
        <link href="/ovirt-engine/api/affinitylabels/9a443202-2349-40a2-bff6-320d569aeb26/hosts" rel="hosts"/>
        <link href="/ovirt-engine/api/affinitylabels/9a443202-2349-40a2-bff6-320d569aeb26/vms" rel="vms"/>
        <read_only>false</read_only>
    </affinity_label>

Comment 1 Lucie Leistnerova 2018-05-07 12:14:00 UTC
I'm sorry, I accidentally submit it too early.


Description of problem:
Element affinity_label is not the same from specific vm as the one in main affinitylabels result.

Version-Release number of selected component (if applicable):
ovirt-engine-restapi-4.2.3.5-0.1.el7.noarch

How reproducible: always

Comment 2 Lucie Leistnerova 2018-06-01 07:52:29 UTC
Elements <affinity_label> are the same now.

verified in ovirt-engine-restapi-4.2.4.1-0.1.el7.noarch

Comment 3 Sandro Bonazzola 2018-06-26 08:45:44 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.