Bug 1575625 - vmx: vmwrite errors flooding dmesg/console: vmwrite error: reg 401e value 2020 (err 12)
Summary: vmx: vmwrite errors flooding dmesg/console: vmwrite error: reg 401e value 202...
Keywords:
Status: CLOSED DUPLICATE of bug 1566258
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 13:04 UTC by Frank Ch. Eigler
Modified: 2018-05-07 13:16 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 13:16:22 UTC
Type: Bug


Attachments (Terms of Use)

Description Frank Ch. Eigler 2018-05-07 13:04:17 UTC
Description of problem:

On an old but well-working server (Dual Xeon 5150), a recent f27 kernel update has made qemu/kvm useless on the machine by slowing it to an absolute crawl.  Guest OS doesn't seem to matter (observed both with rhel7 and win10), though post-spectre-ness is possibly related.  The following type of message is printed endlessly to the console:

[ 2913.089185] vmwrite error: reg 401e value 2020 (err 12)
[ 2913.096191] CPU: 0 PID: 5854 Comm: CPU 0/KVM Not tainted 4.16.5-200.fc27.x86_64 #1
[ 2913.103323] Hardware name: Dell Inc. PowerEdge 2900/0J7551, BIOS 2.6.1 04/20/2009
[ 2913.110501] Call Trace:
[ 2913.117718]  dump_stack+0x5c/0x85
[ 2913.124929]  vmx_set_cr4+0x1cf/0x200 [kvm_intel]
[ 2913.132200]  ? vmexit_fill_RSB+0x18/0x30 [kvm_intel]
[ 2913.139529]  kvm_set_cr4+0x18e/0x2c0 [kvm]
[ 2913.146844]  handle_cr+0x5a8/0x650 [kvm_intel]
[ 2913.154184]  vmx_handle_exit+0xaf/0x14c0 [kvm_intel]
[ 2913.161530]  ? vmexit_fill_RSB+0xc/0x30 [kvm_intel]
[ 2913.168864]  ? vmexit_fill_RSB+0x18/0x30 [kvm_intel]
[ 2913.176055]  ? vmexit_fill_RSB+0xc/0x30 [kvm_intel]
[ 2913.183089]  ? vmx_vcpu_run+0x367/0x520 [kvm_intel]
[ 2913.190064]  kvm_arch_vcpu_ioctl_run+0x699/0x16e0 [kvm]
[ 2913.197026]  ? kvm_vcpu_mmap+0x20/0x20 [kvm]
[ 2913.203930]  ? kvm_vcpu_ioctl+0x32b/0x5d0 [kvm]
[ 2913.210764]  kvm_vcpu_ioctl+0x32b/0x5d0 [kvm]
[ 2913.217479]  ? __switch_to+0x468/0x4c0
[ 2913.224085]  do_vfs_ioctl+0xa4/0x620
[ 2913.230587]  SyS_ioctl+0x74/0x80
[ 2913.236917]  do_syscall_64+0x74/0x180
[ 2913.243269]  entry_SYSCALL_64_after_hwframe+0x3d/0xa2
[ 2913.249638] RIP: 0033:0x7f7f471870f7
[ 2913.255987] RSP: 002b:00007f7f3993a878 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
[ 2913.262537] RAX: ffffffffffffffda RBX: 0000000000000001 RCX: 00007f7f471870f7
[ 2913.269174] RDX: 0000000000000000 RSI: 000000000000ae80 RDI: 000000000000000f
[ 2913.275839] RBP: 0000560505c69e80 R08: 0000560505c84230 R09: 000000000000ffff
[ 2913.282542] R10: 0000560508f735a0 R11: 0000000000000246 R12: 00005605077b6cb6
[ 2913.289356] R13: 0000000000000000 R14: 00007f7f5085c000 R15: 00005605077b6c20



I don't much care if spectre/meltdown protection doesn't work well in the guests or the host for that matter.  But these messages are bogging the server down by factors of 100.


Version-Release number of selected component (if applicable):
kernel-4.16.5-200.fc27.x86_64
qemu-kvm-2.10.1-3.fc27.x86_64

Comment 1 Jeremy Cline 2018-05-07 13:16:22 UTC
Hi Frank,

Thanks for the report. This looks like a known issue (you can confirm by testing https://koji.fedoraproject.org/koji/taskinfo?taskID=26538797). There's a patch that's been submitted upstream. It's not made its way into the KVM tree, though. Once I see a KVM maintainer accept it I'll put it in the Fedora stable builds.

*** This bug has been marked as a duplicate of bug 1566258 ***


Note You need to log in before you can comment on or make changes to this bug.