Bug 1575649 - inconsolata font no longer shows bold characters in xterm
Summary: inconsolata font no longer shows bold characters in xterm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: 28
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 14:12 UTC by Stefan Assmann
Modified: 2018-05-14 17:54 UTC (History)
15 users (show)

Fixed In Version: fontconfig-2.13.0-4.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-14 17:54:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 106460 None None None 2018-05-10 12:33:22 UTC

Description Stefan Assmann 2018-05-07 14:12:43 UTC
Description of problem:
Using the inconsolata font in xterm no longer shows bold text as bold. Text is displayed as normal.
Not seeing the problem using LiberationMono or DejaVuSansMono, therefore I assume the problem is related to the font.

Version-Release number of selected component (if applicable):
xterm-331-1.fc28.x86_64
levien-inconsolata-fonts-1.01-16.fc28.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf install levien-inconsolata-fonts.noarch
2. echo "xterm*faceName: Inconsolata:size=10" > ~/.Xresources
3. xrdb load ~/.Xresources
4. run the following in newly started xterm: echo -e "\e[1mbold\e[0m"

Actual results:
bold text is displayed as "normal"

Expected results:
bold text is displayed as "bold"

Additional info:
Still worked in F27.

Comment 1 Stefan Assmann 2018-05-07 14:14:23 UTC
Ccing Miroslav in case something in xterm changed.

Comment 2 Miroslav Lichvar 2018-05-09 06:39:12 UTC
It might be an xterm issue. Could you please try it with xterm-330 and xterm-333?

Comment 3 Stefan Assmann 2018-05-09 08:21:19 UTC
compiled both xterm-330 and xterm-333 from upstream source. Exactly the same behaviour, bold text is not bold.

Comment 4 Miroslav Lichvar 2018-05-10 10:52:08 UTC
I tried downgrading different packages and it seems to be caused by a change in fontconfig. With fontconfig-2.12.6-4.fc28 it still works, but with fontconfig-2.12.93-1.fc28 it does not.

Comment 5 Akira TAGOH 2018-05-10 12:32:37 UTC
apparently https://cgit.freedesktop.org/fontconfig/commit/?id=9efe0689ae130eda75a66ecd853cbe63712378a3 affects to this behavior. need to revisit this to get the right behavior.

Comment 6 Fedora Update System 2018-05-11 13:53:25 UTC
fontconfig-2.13.0-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4f606efb2e

Comment 7 Fedora Update System 2018-05-12 19:35:11 UTC
fontconfig-2.13.0-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4f606efb2e

Comment 8 Fedora Update System 2018-05-14 17:54:30 UTC
fontconfig-2.13.0-4.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.