Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1575651 - Vim Dependency broken
Summary: Vim Dependency broken
Keywords:
Status: CLOSED DUPLICATE of bug 1575354
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 14:21 UTC by LiZhenbo
Modified: 2018-05-08 06:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-08 06:29:32 UTC
Type: Bug


Attachments (Terms of Use)

Description LiZhenbo 2018-05-07 14:21:08 UTC
$ sudo dnf upgrade

Last metadata expiration check: 1:13:10 ago on Mon 07 May 2018 09:06:04 AM EDT.
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package vim-X11-2:8.0.1763-1.fc28.x86_64
  - nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-X11-2:8.0.1788-1.fc28.x86_64
 Problem 2: cannot install the best update candidate for package vim-enhanced-2:8.0.1763-1.fc28.x86_64
  - nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-enhanced-2:8.0.1788-1.fc28.x86_64
 Problem 3: package vim-enhanced-2:8.0.1763-1.fc28.x86_64 requires vim-common = 2:8.0.1763-1.fc28, but none of the providers can be installed
  - cannot install both vim-common-2:8.0.1788-1.fc28.x86_64 and vim-common-2:8.0.1763-1.fc28.x86_64
  - problem with installed package vim-enhanced-2:8.0.1763-1.fc28.x86_64
  - cannot install the best update candidate for package vim-common-2:8.0.1763-1.fc28.x86_64
  - nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-enhanced-2:8.0.1788-1.fc28.x86_64
========================================================================================================================
 Package                      Arch                   Version                              Repository               Size
========================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 vim-common                   x86_64                 2:8.0.1788-1.fc28                    updates                 6.4 M
Skipping packages with broken dependencies:
 vim-X11                      x86_64                 2:8.0.1788-1.fc28                    updates                 1.4 M
 vim-enhanced                 x86_64                 2:8.0.1788-1.fc28                    updates                 1.3 M

Transaction Summary
========================================================================================================================
Skip  3 Packages

Nothing to do.
Complete!

Comment 1 Michele Baldessari 2018-05-08 06:29:32 UTC

*** This bug has been marked as a duplicate of bug 1575354 ***


Note You need to log in before you can comment on or make changes to this bug.