Bug 1575652 - RBD - postpone snapshot removal until final volume deleted (deferred deletion)
Summary: RBD - postpone snapshot removal until final volume deleted (deferred deletion)
Keywords:
Status: CLOSED DUPLICATE of bug 1870282
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 15.0 (Stein)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: z2
: 16.1 (Train on RHEL 8.2)
Assignee: Jon Bernard
QA Contact: Tzach Shefi
RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks: 1870282
TreeView+ depends on / blocked
 
Reported: 2018-05-07 14:21 UTC by Sean Cohen
Modified: 2020-12-14 11:03 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1254470
: 1870282 (view as bug list)
Environment:
Last Closed: 2020-08-19 16:24:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1485897 0 None None None 2018-05-07 14:21:30 UTC
OpenStack gerrit 608984 0 'None' MERGED Support deferred deletion in RBD 2021-02-11 13:26:00 UTC

Comment 3 Eric Harney 2019-04-18 13:31:42 UTC
Feature: deferred deletion for the RBD driver

https://review.openstack.org/#/c/608984/

Comment 13 Tzach Shefi 2019-11-05 07:09:36 UTC
Greg,
As we are already QA-acked on this, removing needinfo.

Comment 25 Gregory Charot 2020-08-19 16:24:53 UTC
16.x we want to leverage clone v2 as a clean way to cover this use case. https://bugzilla.redhat.com/show_bug.cgi?id=1764324

Closing this as this will be tracked by https://bugzilla.redhat.com/show_bug.cgi?id=1870282 for OSP13.

*** This bug has been marked as a duplicate of bug 1870282 ***


Note You need to log in before you can comment on or make changes to this bug.