Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1575703 - cannot change management network interface
Summary: cannot change management network interface
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.2.3
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Dominik Holler
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 16:58 UTC by Max
Modified: 2018-05-16 07:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-16 07:24:26 UTC
oVirt Team: Network


Attachments (Terms of Use)
ovirt-engine log (470.19 KB, text/plain)
2018-05-07 16:58 UTC, Max
no flags Details
ovirtmgmt dialog (117.17 KB, image/png)
2018-05-08 09:34 UTC, Max
no flags Details

Description Max 2018-05-07 16:58:48 UTC
Created attachment 1432725 [details]
ovirt-engine log

Description of problem:
We have a box with OVH.  The box has two network adapters installed, however, one is for their vRack service.  oVirt, by default, chooses the vRack Ethernet adapter during host install.  When I try to reassign the Logical Network ovritmgmt to the active interface I get the error:

Cannot setup Networks. The following Networks' definitions on the Network Interfaces are different than those on the Logical Networks. Please synchronize the Network Interfaces before editing the networks: ovirtmgmt.

I have repeatedly tried "Sync All Networks." But the above error always appears.  I have not found any documentation or discussion on this error.

Version-Release number of selected component (if applicable):
4.2.3.5-1.el7.centos

How reproducible:
Always.  I've reinstalled the OS four times.

Steps to Reproduce:
1. Rent a server from OVH that has vRack.
2. Install CentOS 7.
3. Install oVirt 4.2.
4. Try to do single host install.
5. Network errors out.

Actual results:
Always errors with the error above when trying to reassign ovirtmgmt Logical Network.

Expected results:
That I can reassign the Logical Network.

Additional info:

Comment 1 Max 2018-05-07 18:21:14 UTC
Also, to note, there is no IP associated with the vRack interface since we do not use it.

Comment 2 Sandro Bonazzola 2018-05-08 08:32:43 UTC
Not sure if it may help, but I found this one.
re-assigning the bug to network team engineers.

Comment 3 Sandro Bonazzola 2018-05-08 08:34:53 UTC
(In reply to Sandro Bonazzola from comment #2)
> Not sure if it may help, but I found this one.
> re-assigning the bug to network team engineers.

https://lists.ovirt.org/archives/list/users@ovirt.org/message/RVFCIGF7RZNPZWINORUQJHK2WYBRUJS6/

Comment 4 Dominik Holler 2018-05-08 09:30:40 UTC
(In reply to Max from comment #0)

> 
> Steps to Reproduce:
> 1. Rent a server from OVH that has vRack.
> 2. Install CentOS 7.
> 3. Install oVirt 4.2.
> 4. Try to do single host install.

Does this mean the whole scenario is executed on a single server, which is added as a host with the IP address 127.0.0.1?

The information which attribute is not in sync is provided in the "Setup Host Networks" dialog in a tooltip if the mouse pointer hovers the interface, e.g. like in
https://lists.ovirt.org/archives/list/users@ovirt.org/message/HHQBURXO7MUBNJBPIHUBA7CT6JCWIDDI/attachment/3/dialog.jpg
Can you share a similar screenshot?

Comment 5 Max 2018-05-08 09:34:17 UTC
Created attachment 1433108 [details]
ovirtmgmt dialog

Dialog showing ovirtmgmt with no IP.

Comment 6 Max 2018-05-08 09:35:58 UTC
Hi,

Yes, the whole scenario is I'm installing oVirt on a single server.  Then I added localhost as a host.

The problem appears to be due to the fact that the vRack interface has no IP.  But oVirt still chooses it for the ovirtmgmt interface anyway.

Comment 7 Dominik Holler 2018-05-08 09:51:10 UTC
(In reply to Max from comment #5)
> Created attachment 1433108 [details]
> ovirtmgmt dialog
> 
> Dialog showing ovirtmgmt with no IP.

This dialog shows that the property "Default route" is not synced.
I guess the role "Default Route" should be assigned to the Logical Network "public" in your scenario.
The role can be assigned in
In Administration Portal > Compute > Clusters > CLUSTERNAME_OF_THE_HOST (e.g. Default or OVH) > Logical Networks > Manage Networks.

Does this solve the issue?

Comment 8 Dominik Holler 2018-05-08 10:36:36 UTC
(In reply to Max from comment #6)
> Hi,
> 
> Yes, the whole scenario is I'm installing oVirt on a single server.  Then I
> added localhost as a host.
> 
> The problem appears to be due to the fact that the vRack interface has no
> IP.  But oVirt still chooses it for the ovirtmgmt interface anyway.

The interface is chosen according to the IP address used to add the host.
If you want eno1 for ovirtmgmt, use the IP address of eno1 or hostname mapped to eno1's IP address.

Comment 9 Max 2018-05-08 10:52:25 UTC
Ok.  I'm going to reinstall the OS and try adding the host via the public facing IP.

But I still do think of it as a bug that in the localhsot setup it chooses a unused interface that has no IP.

Comment 10 Max 2018-05-14 16:17:33 UTC
Well, I fixed it on my install, as my last comment states, by reinstalling the OS and resetting up oVirt using the public IP rather than loopback.  However, when the problem was occurring it did not allow me to manage the interface "ovirtmgmt" at all.  As all the logs stated that it couldn't communicate with the host basically.

Comment 11 Dan Kenigsberg 2018-05-16 07:24:26 UTC
It is unfortunate, but we cannot change the IP address of the management network. The only sane resolution of this condition is, as you have found, it to redeploy the host.


Note You need to log in before you can comment on or make changes to this bug.