Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1575712 - Fedora 28 contains pdfresurrect from fc22
Summary: Fedora 28 contains pdfresurrect from fc22
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pdfresurrect
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 17:26 UTC by Michal Ambroz
Modified: 2018-07-11 11:59 UTC (History)
2 users (show)

Fixed In Version: pdfresurrect-0.12-11.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-11 11:59:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Michal Ambroz 2018-05-07 17:26:39 UTC
Description of problem:
The Fedora 28 contains pdfresurrect version from fedora 22. There is something strange there. There are commits from mass rebuild attempts for Fedora 28, but still the build is old fedore 22.

Version-Release number of selected component (if applicable):
# dnf install pdfresurrect
Last metadata expiration check: 3:06:07 ago on Mon 07 May 2018 04:16:34 PM CEST.
Dependencies resolved.
===================================================================================================================================================================================================================
 Package                                               Arch                                            Version                                               Repository                                       Size
===================================================================================================================================================================================================================
Installing:
 pdfresurrect                                          x86_64                                          0.12-5.fc22                                           fedora                                           36 k


How reproducible:
100%

Steps to Reproduce:
1. dnf install pdfresurrect
2. check for latest version in koji.fedoraproject.org


Actual results:
package built for fedora 22 is installed

Expected results:
I would expect package built for fedora 28 to be installed


Additional info:
I believe the best solution would be to bump to version 0.14 and distribute as a update. 
Please see the pull request:
https://src.fedoraproject.org/rpms/pdfresurrect/pull-request/1

Comment 1 Till Maas 2018-05-29 07:06:46 UTC
The builds failed early in the process, see #1583289 and the old releng bug reporting scripts did not catch this case. It is now rebuilt in F29. Would you mind starting the nonresponsive maintainer process and take over the package? 

https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers

Comment 2 Peter Lemenkov 2018-05-30 13:32:45 UTC
(In reply to Till Maas from comment #1)
> The builds failed early in the process, see #1583289 and the old releng bug
> reporting scripts did not catch this case. It is now rebuilt in F29. Would
> you mind starting the nonresponsive maintainer process and take over the
> package? 
> 
> https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers

I don't see any other open bugs related to pdfresurrect. How I suppose to react if I didn't see any warnings at all?

Comment 3 Till Maas 2018-05-30 14:25:26 UTC
(In reply to Peter Lemenkov from comment #2)
 
> I don't see any other open bugs related to pdfresurrect. How I suppose to
> react if I didn't see any warnings at all?

Did not mean to offend you, if you will be working on this, it is great. Just wondering, did you also not get any notifications about the failures from koji?


Note You need to log in before you can comment on or make changes to this bug.