Bug 1575749 - Multiple AVC for geoclue (geoclue),init_t,geoclue_exec_t,file,execute_no_trans
Summary: Multiple AVC for geoclue (geoclue),init_t,geoclue_exec_t,file,execute_no_trans
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 19:28 UTC by Paul DeStefano
Modified: 2018-09-12 02:56 UTC (History)
5 users (show)

Fixed In Version: selinux-policy-3.14.2-34.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-12 02:56:31 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul DeStefano 2018-05-07 19:28:38 UTC
Description of problem:
Platform                      Linux hostname 4.17.0-0.rc3.git4.1.fc29.x86_64 #1
                              SMP Fri May 4 19:41:58 UTC 2018 x86_64 x86_64
Alert Count                   2
First Seen                    2018-05-07 00:01:24 PDT
Last Seen                     2018-05-07 00:01:52 PDT
Local ID                      2a04dda0-5017-43ad-868d-8bcc43fab59e

Raw Audit Messages
type=AVC msg=audit(1525676512.509:223): avc:  denied  { execute_no_trans } for  pid=1909 comm="(geoclue)" path="/usr/libexec/geoclue" dev="dm-0" ino=532927 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:geoclue_exec_t:s0 tclass=file permissive=0


Hash: (geoclue),init_t,geoclue_exec_t,file,execute_no_trans

First Seen                    2018-05-07 00:01:24 PDT
Last Seen                     2018-05-07 00:01:52 PDT
Local ID                      0b7ea59d-7d09-4537-b7e9-6be7ba65597e

Raw Audit Messages
type=AVC msg=audit(1525676512.508:221): avc:  denied  { nnp_transition } for  pid=1909 comm="(geoclue)" scontext=system_u:system_r:init_t:s0 tcontext=system_u:system_r:geoclue_t:s0 tclass=process2 permissive=0


Also, this AVC:
Hash: (geoclue),init_t,geoclue_t,process2,nnp_transition
Version-Release number of selected component (if applicable):


How reproducible:
Occurs on login, since last update.

Comment 1 Jan Kurik 2018-08-14 11:19:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 2 Fedora Update System 2018-09-11 12:50:15 UTC
selinux-policy-3.14.2-34.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-db240a1726

Comment 3 Fedora Update System 2018-09-12 02:56:31 UTC
selinux-policy-3.14.2-34.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.