Bug 1575770 - inkscape crash in Inkscape::UI::Tools::perform_bitmap_scanline_check
Summary: inkscape crash in Inkscape::UI::Tools::perform_bitmap_scanline_check
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: inkscape
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1679489 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 21:01 UTC by Michal Ambroz
Modified: 2019-04-06 19:43 UTC (History)
10 users (show)

Fixed In Version: inkscape-0.92.4-5.fc30 inkscape-0.92.4-5.fc28 inkscape-0.92.4-5.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-02 00:01:44 UTC


Attachments (Terms of Use)
test.svg (46.46 KB, image/svg+xml)
2018-05-07 21:01 UTC, Michal Ambroz
no flags Details
core_backtrace (23.50 KB, text/plain)
2018-05-07 21:04 UTC, Michal Ambroz
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1778951 None None None 2018-06-27 16:32:57 UTC

Description Michal Ambroz 2018-05-07 21:01:36 UTC
Created attachment 1432829 [details]
test.svg

Description of problem:
Inkscape crashes in Inkscape::UI::Tools::perform_bitmap_scanline_check when filling area from bucket. There is something special about this test file. It was created by importing some pdf file.


Version-Release number of selected component (if applicable):
inkscape-0.92.3-1.fc28


How reproducible:
100%

Steps to Reproduce:
1. open attached file test.svg
2. chose the bucket tool
3. click fill on the red are of the test.svg

Actual results:
crash

Expected results:
should fill the area

Additional info:

Comment 1 Michal Ambroz 2018-05-07 21:04:09 UTC
Created attachment 1432830 [details]
core_backtrace

Comment 2 Dominik 'Rathann' Mierzejewski 2018-07-15 20:48:32 UTC
I can reproduce this with a file I created on my own. I can share the file privately if necessary, but would like to avoid posting it publicly.

inkscape-0.92.3-2.fc28.x86_64

Comment 3 Edouard Lefebvre 2018-08-01 09:29:13 UTC
I'm seeing the same bug when trying to fill any area from bucket. 

How can I help?

Inkscape 0.92.3-2.fc28

Comment 4 Jonathan Underwood 2019-01-26 14:23:24 UTC
Observed consistently on Fedora 29 as well. inkscape-0.92.3-5.fc29.x86_64

Comment 5 Jonathan Underwood 2019-01-26 14:25:53 UTC
The linked upstream bug report indicates that this problem is a packaging issue: the Fedora package exhibits the bug, but a hand compiled version does not.

Comment 6 Jalal Ahmed 2019-02-16 15:29:46 UTC
The issue is continuing with 0.92.4 version.

Comment 7 Jalal Ahmed 2019-02-16 17:53:02 UTC
I've asked in inkscape-devel IRC channel room, and Mc has responded to this:
(that's because fedora packagers use -D_FORTIFY_SOURCE=2; these kind of bugs that were only reproducible on fedora before we knew why will slowly be fixed in the future now that I know how to cause them)

Comment 8 Gwyn Ciesla 2019-02-19 16:11:14 UTC
Does it still happen with 0.92.4-4?

Comment 9 Jalal Ahmed 2019-02-19 16:58:53 UTC
Yes, the problem is carrying on with 0.92.4-4, and the problem is with RPM file and flatpak as well.
A way to produce the issue:

Draw a circle and a square and select them, then go to Path >> Division you will end up with a crash which closes the app

Comment 10 Gwyn Ciesla 2019-02-19 17:26:25 UTC
Ok, thanks. I can reproduce that, and I've offered to help upstream.

Comment 11 Gwyn Ciesla 2019-02-21 15:45:06 UTC
*** Bug 1679489 has been marked as a duplicate of this bug. ***

Comment 12 Steven Bakker 2019-03-26 22:24:04 UTC
Is there any possibility of rebuilding the package *without* -D_FORTIFY_SOURCE=2? Right now, inkscape is totally unusable.

Comment 13 Gwyn Ciesla 2019-03-27 14:57:15 UTC
Yes. I was hoping to see movement on the upstream bug, but we can do this for the interim. Updates forthcoming.

Comment 14 Fedora Update System 2019-03-27 20:48:46 UTC
inkscape-0.92.4-5.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-67616f15b6

Comment 15 Fedora Update System 2019-03-27 20:48:55 UTC
inkscape-0.92.4-5.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4411c81065

Comment 16 Fedora Update System 2019-03-27 20:49:03 UTC
inkscape-0.92.4-5.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-66255a2c48

Comment 17 Jalal Ahmed 2019-03-28 01:46:05 UTC
The issue has been solved in inkscape-0.92.4-5, thank you Gwyn Ciesla.

Comment 18 Fedora Update System 2019-03-29 00:12:31 UTC
inkscape-0.92.4-5.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-66255a2c48

Comment 19 Fedora Update System 2019-03-29 03:05:26 UTC
inkscape-0.92.4-5.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-67616f15b6

Comment 20 Fedora Update System 2019-03-29 04:15:38 UTC
inkscape-0.92.4-5.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4411c81065

Comment 21 Fedora Update System 2019-04-02 00:01:44 UTC
inkscape-0.92.4-5.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2019-04-06 19:21:41 UTC
inkscape-0.92.4-5.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2019-04-06 19:43:10 UTC
inkscape-0.92.4-5.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.