Bug 1575820 - logging-curator pods can not be started up
Summary: logging-curator pods can not be started up
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.7.z
Assignee: Jeff Cantrill
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1557483 1559162
TreeView+ depends on / blocked
 
Reported: 2018-05-08 03:05 UTC by Junqi Zhao
Modified: 2018-06-27 07:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-06-27 07:59:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2009 0 None None None 2018-06-27 07:59:48 UTC

Description Junqi Zhao 2018-05-08 03:05:06 UTC
Description of problem:
logging-curator pods can not be started up.
# oc get po
NAME                                      READY     STATUS             RESTARTS   AGE
logging-curator-1-d9l5q                   0/1       CrashLoopBackOff   4          3m
logging-curator-1-deploy                  1/1       Running            0          3m
logging-es-data-master-6ybzgqk7-1-p4qh8   2/2       Running            0          2m
logging-fluentd-h4hgv                     1/1       Running            0          2m
logging-fluentd-svpwj                     1/1       Running            0          2m
logging-kibana-1-svqhk                    2/2       Running            0          3m

# oc logs logging-curator-1-d9l5q
sh: run.sh: No such file or directory

# docker run -it brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/logging-curator:v3.7.46-1 /bin/bash
bash-4.2$ ls
__init__.py  curator_cmd.py  parser.py	run_cron.py  util.py


Version-Release number of selected component (if applicable):
logging-curator/images/v3.7.46-1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
logging-curator pods can not be started up

Expected results:
logging-curator pods could be started up

Additional info:

Comment 2 Junqi Zhao 2018-05-09 05:40:58 UTC
Blocks curator functions

Comment 3 Anping Li 2018-05-10 09:57:46 UTC
@Samuel, Could you rebuild this curator image to include the fix of this bug. If this bug couldn't be fixed.  we must remove logging-curator image from v3.7 errata.

Comment 4 Anping Li 2018-05-22 07:59:23 UTC
works well with logging-curator:v3.7.48

Comment 6 errata-xmlrpc 2018-06-27 07:59:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2009


Note You need to log in before you can comment on or make changes to this bug.