Bug 1575824 - Unusual naming for USB devices
Summary: Unusual naming for USB devices
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.2
Hardware: x86_64
OS: Linux
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact: meital avital
Depends On:
Blocks: 1511234
TreeView+ depends on / blocked
Reported: 2018-05-08 03:51 UTC by Germano Veit Michel
Modified: 2019-05-16 13:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2018-05-08 06:35:46 UTC
oVirt Team: Virt
Target Upstream Version:

Attachments (Terms of Use)

Description Germano Veit Michel 2018-05-08 03:51:53 UTC
Description of problem:

The naming for USB hostdev differs from other device types.

usb hostdev from 'bus=1 device=1' -> name: usb_usb1
usb hostdev from 'bus=3 device=6' -> name: usb_3_6

So if the bus is 1, the device is named usb_usbX. If the bus is not 1, it is named usb_X_Y. Not sure if there are other variants.

Why not use usb_X_Y structure like the other hostdev devices like pci and scsi?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Add a USB hostdev from bus 1 to a VM
2. Add a USB hostdev from bus != 1 to a VM
3. Check the names of the devices in the 'Host Devices' tab of the VM.

Actual results:
Inconsistent naming

Expected results:
Consistent naming

Additional information:
IIUC, buildVmUsbSlots() has always been like this, always adding USB_BUS.

Comment 1 Michal Skrivanek 2018-05-08 06:35:46 UTC
That's internal naming we get from libvirt. usb_usb1 is the root hub and usb_1_X are devices in it. Nothing we can control

In 4.2 when running on el7.5 you'll get device aliases for consistent unique identification of devices if needed

Comment 2 Germano Veit Michel 2018-05-08 07:03:38 UTC
Got it, thanks Michal!

Comment 3 Franta Kust 2019-05-16 13:05:00 UTC
BZ<2>Jira Resync

Note You need to log in before you can comment on or make changes to this bug.