Bug 1575830 - System Requirements for OCP 3.9 Incorrect with regard to RHEL version
Summary: System Requirements for OCP 3.9 Incorrect with regard to RHEL version
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.9.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Vikram Goyal
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 04:26 UTC by Johnray Fuller
Modified: 2018-05-08 12:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-08 12:34:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Johnray Fuller 2018-05-08 04:26:36 UTC
Document URL: 

https://access.redhat.com/documentation/en-us/openshift_container_platform/3.9/html-single/installation_and_configuration/#system-requirements

Also:

https://docs.openshift.com/container-platform/3.9/install_config/install/host_preparation.html#host-registration


Section Number and Name: 

2.2.1.2. Minimum Hardware Requirements

Describe the issue: 

The Minimum Hardware Requirements specifies that customer install a Base OS of RHEL 7.3, 7.4, or 7.5

But the tested integrations page for OCP shows only 7.4 and 7.5 is supported.

https://access.redhat.com/articles/2176281

Suggestions for improvement: 

I think the section about the base install is intended to say, start with RHEL 7.3, 7.4, 7.5 and run Ansible while subscribed to the rhel-server channels (which will bring the system up to 7.5).

But customers take this to mean that they can run OCP 3.9 on RHEL 7.3, 7.4 or 75. But this is not true.

Additional information: 

NOTE: There are even reports of an RPM dependency issue with 7.4 itemized here.

https://gist.github.com/zetaab/067b01a76767ce01e0de85ff3c516cf2

So it is also worth noting, that container-selinux-2.55-1.el7.noarch (in rhel-extras) requires packages only available in 7.5.




Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information:

Comment 2 Johnray Fuller 2018-05-08 08:03:32 UTC
<Replying publicly as I see no reason to not have this discussion publicly>

The issue is simple:

The installation guide implies you can run OCP 3.9 on 7.3, 7.4, or 7.5.

The passage I am referring to is as follows:

"Base OS: RHEL 7.3, 7.4, or 7.5 with the "Minimal" installation option and the latest packages from the Extras channel, or RHEL Atomic Host 7.4.5 or later."

The tested integration page states we have tested 7.4 and 7.5 only and doesn't mention 7.3 because *Red Hat doesn't test OCP 3.9 on RHEL 7.3*.

So to clear up this wording, a statement that the run time version of the OS for OCP will *not* be 7.3 by the time the installation is finished would help to prevent such misunderstandings.

As for the conversation about the extras repo, it is the source of the RPM dependency issue I mention in passing (which is also no in our documentation) but this is not the focus of this bug.

Comment 3 Carsten Lichy-Bittendorf 2018-05-08 08:21:21 UTC
so you're saying that if you configure

$ subscription-manager release --set=7.3
$ subscription-manager repos --enable="rhel-7-server-eus-rpms" \
    --enable="rhel-7-server-extras-rpms" \
    --enable="rhel-7-server-ose-3.9-rpms" \
    --enable="rhel-7-fast-datapath-rpms" \
    --enable="rhel-7-server-ansible-2.4-rpms"

your node ends up after OCP install on RHEL >7.3?

Comment 4 Johnray Fuller 2018-05-08 08:38:19 UTC
I am confused about the focus on repos and other technical minutia.

I never mentioned setting a release in subscription manager to 7.3 or anything of the sort. The issue around container-selinux-2.55-1.el7.noarch was noted as an aside.

*Again* what I am saying is that telling people in the Minimum Hardware Requirements section of the installation that a minimal system installed for OCP 3.9 can be RHEL 7.3 has confused numerous customers about whether or not OCP 3.9 on 7.3 is a supported configuration. According to our tested integrations page, OCP 3.9 + RHEL 7.3 is not a supported configuration.

The comments about subscription manager, setting releases, and the like is orthogonal to the point of this bug.

Comment 5 Carsten Lichy-Bittendorf 2018-05-08 08:57:07 UTC
a tested configuration is by definition a supported configuration, but the supported configurations are not necessarily limited to the tested one, but to my understanding.

Comment 6 Johnray Fuller 2018-05-08 09:07:53 UTC
If one follows the instructions in the installation guide, I believe you end up with a 7.5 system running OCP 3.9. So the installation presented in our documentation pushes one to 7.5 automatically. But the wording of the minimal requirements section implies 7.3 will work. This is inaccurate.

As for your statement regarding the tested configurations page, it is absolutely used as a guide for customers as to what is supported with regards to OpenShift. 

https://access.redhat.com/articles/2176281

If you read the page, it captures the RHEL version at release time of the OCP release. However, states that newer versions are supported. Here is the relevant passage:

"Red Hat provides both production and development support for the tested integrations in the same major version family at or above the tested version according to your subscription agreement. Earlier versions of a tested integration in the same major version family are supported on a commercially reasonable basis."

From this passage, one can then say Red Hat does not support OCP 3.9 and RHEL 7.3.

Or documentation should match this point.

Comment 7 Johnray Fuller 2018-05-08 12:34:41 UTC
In an email with the CEE product manager for OCP, he said the docs are authoritative and the knowledgebase article, despite the wording cited in the bug, is not related to supportability. So I am closing this bug.


Note You need to log in before you can comment on or make changes to this bug.