Bug 1575836 - logic in S30samba-start.sh hook script needs tweaking
Summary: logic in S30samba-start.sh hook script needs tweaking
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: scripts
Version: mainline
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anoop C S
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1541568
TreeView+ depends on / blocked
 
Reported: 2018-05-08 05:10 UTC by Anoop C S
Modified: 2019-03-25 16:30 UTC (History)
4 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1541568
Environment:
Last Closed: 2019-03-25 16:30:27 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 19204 0 None Merged Do not blindly add volume share section to smb.conf 2018-12-04 16:37:26 UTC

Description Anoop C S 2018-05-08 05:10:59 UTC
+++ This bug was initially created as a clone of Bug #1541568 +++

Description of problem: 

Hiding unwanted error messages
- /var/lib/glusterd/hooks/1/start/post/S30samba-start.sh: line 71: smbd: command not found
- Samba is not installed + exit code '1' should be enough

Bad script logic
- volume info file needs to be checked for presence of all configuration possibilities 'user.smb|user.cifs' = 'enable|on'

Version-Release number of selected component (if applicable):
mainline

Comment 1 Anoop C S 2018-09-09 06:57:32 UTC
(In reply to Anoop C S from comment #0)
> Hiding unwanted error messages
> - /var/lib/glusterd/hooks/1/start/post/S30samba-start.sh: line 71: smbd:
> command not found
> - Samba is not installed + exit code '1' should be enough

See https://review.gluster.org/c/glusterfs/+/21124

> Bad script logic
> - volume info file needs to be checked for presence of all configuration
> possibilities 'user.smb|user.cifs' = 'enable|on'
> 
> Version-Release number of selected component (if applicable):
> mainline

https://review.gluster.org/c/glusterfs/+/19204 will be re-considered for reconciling the logic used.

Comment 2 Worker Ant 2018-09-09 07:00:25 UTC
REVIEW: https://review.gluster.org/19204 (Fix logic in S30samba-start.sh hook script) posted (#7) for review on master by Anoop C S

Comment 3 Worker Ant 2018-12-04 16:37:24 UTC
REVIEW: https://review.gluster.org/19204 (Do not blindly add volume share section to smb.conf) posted (#9) for review on master by Amar Tumballi

Comment 4 Shyamsundar 2019-03-25 16:30:27 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.