Bug 1575844 - neutron_tempest_plugin.api.admin.test_quotas.QuotasTest.test_detail_quotas test failed on CI
Summary: neutron_tempest_plugin.api.admin.test_quotas.QuotasTest.test_detail_quotas te...
Keywords:
Status: CLOSED DUPLICATE of bug 1572578
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Assaf Muller
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 05:40 UTC by Eran Kuris
Modified: 2019-09-09 16:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-16 13:42:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eran Kuris 2018-05-08 05:40:19 UTC
Description of problem:
neutron_tempest_plugin.api.admin.test_quotas.QuotasTest.test_detail_quotas test failed on CI run

430a-b9c4-4eedb2d47b5a'}
        Body: 
2018-05-06 10:37:50,574 1354 INFO     [tempest.lib.common.rest_client] Request (QuotasTest:_run_cleanups): 204 DELETE http://10.0.0.102:9696/v2.0/quotas/70fc8c2ec3cb4c9bb23cea2658595b64 0.030s
2018-05-06 10:37:50,575 1354 DEBUG    [tempest.lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'status': '204', u'content-length': '0', 'content-location': 'http://10.0.0.102:9696/v2.0/quotas/70fc8c2ec3cb4c9bb23cea2658595b64', u'date': 'Sun, 06 May 2018 14:37:50 GMT', u'connection': 'close', u'x-openstack-request-id': 'req-5515b01c-2a7c-4eb1-a35a-4ad5086dae82'}
        Body:
}}}

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/common/utils/__init__.py", line 107, in wrapper
    return func(*func_args, **func_kwargs)
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/api/admin/test_quotas.py", line 145, in test_detail_quotas
    quota_set[key]['used'])
  File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 350, in assertEqual
    self.assertThat(observed, matcher, message)
  File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 435, in assertThat
    raise mismatch_error
testtools.matchers._impl.MismatchError: 1 != 2

Version-Release number of selected component (if applicable):
OSP-13  -p 2018-05-04.1
openvswitch-ovn-common-2.9.90-1.el7.x86_64
openvswitch-ovn-host-2.9.90-1.el7.x86_64
python-networking-ovn-4.0.1-0.20180420150809.c7c16d4.el7ost.noarch
openvswitch-ovn-central-2.9.90-1.el7.x86_64
puppet-ovn-12.4.0-0.20180329043503.36ff219.el7ost.noarch
python-networking-ovn-metadata-agent-4.0.1-0.20180420150809.c7c16d4.el7ost.noarch
How reproducible:
100%

Steps to Reproduce:
1.run ci job
2.
3.

Actual results:
test failed 

Expected results:
test should pass


Additional info:

Comment 2 Eran Kuris 2018-05-10 12:16:31 UTC
After I debugged the issue and show it to Numan we agree that  
the test failed becuase networking-ovn creates a port for metadata/dhcp when the network is created. so 1 is already used up and later the test creates another port so we reach the limit.

Comment 4 Lucas Alvares Gomes 2018-05-16 13:42:57 UTC

*** This bug has been marked as a duplicate of bug 1572578 ***


Note You need to log in before you can comment on or make changes to this bug.