Bug 1575848 - Dependency missing from repository for texmaker
Summary: Dependency missing from repository for texmaker
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texmaker
Version: rawhide
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 05:45 UTC by jman012345
Modified: 2018-06-08 13:11 UTC (History)
2 users (show)

Fixed In Version: texmaker-5.0.2-5.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-08 13:11:22 UTC
Type: Bug


Attachments (Terms of Use)

Description jman012345 2018-05-08 05:45:29 UTC
Description of problem:

Downloading texmaker fails with:
"Error: 
 Problem: conflicting requests
  - nothing provides tetex-xdvi needed by texmaker-1:5.0.2-4.fc28.x86_64"

Version-Release number of selected component (if applicable):
5.0.2

How reproducible:
Always

Steps to Reproduce:
1. Open Terminal
2. Enter and execute 'sudo dnf install texmaker'

Actual results:
Error message, nothing provides tetex-xdvi

Expected results:
Successful download

Additional info:
This is on a system that has been upgraded to Rawhide from Fedora 27. Texmaker was previously working on the system when running Fedora 27, so the required package is available at least in the Fedora 27 repository.

Comment 1 Mukundan Ragavan 2018-05-08 21:52:51 UTC
Yup!

It looks like texlive-xdvi package is missing which means tetex-xdvi cannot be fulfilled.

I will remove the requires.

Comment 2 Mukundan Ragavan 2018-05-08 22:16:54 UTC
Try this build please

https://koji.fedoraproject.org/koji/taskinfo?taskID=26853388

Comment 3 Mukundan Ragavan 2018-05-08 22:17:16 UTC
Since you are rawhide, if you just update your system, you should get this build.

Comment 4 jman012345 2018-05-09 00:30:52 UTC
(In reply to Mukundan Ragavan from comment #3)
> Since you are rawhide, if you just update your system, you should get this
> build.

The rawhide repository still tries to install the f28 version and fails due to the requires. This problem persists after cleaning all packages, refreshing the repository information, and attempting to install.

Manual installation from the koji link works, though (for the f29 version). I've tested installation, saving a test file, and generating a PDF from it successfully.

Comment 5 Fedora Update System 2018-05-30 16:33:09 UTC
texmaker-5.0.2-5.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-36a74917c7

Comment 6 Fedora Update System 2018-05-31 13:00:58 UTC
texmaker-5.0.2-5.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-36a74917c7

Comment 7 Fedora Update System 2018-06-08 13:11:22 UTC
texmaker-5.0.2-5.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.