Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1575854 - [3.7] Invalid URL shown in upgrade failure msg
Summary: [3.7] Invalid URL shown in upgrade failure msg
Keywords:
Status: CLOSED DUPLICATE of bug 1596448
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 3.7.z
Assignee: Scott Dodson
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 06:02 UTC by Gaoyun Pei
Modified: 2018-11-20 13:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-20 13:52:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gaoyun Pei 2018-05-08 06:02:39 UTC
Description of problem:
When upgrading ocp-3.6 with embedded etcd to ocp-3.7, openshift-ansible will abort and prompt the following failure msg:

TASK [Evaluate groups - Fail if no etcd hosts group is defined] *************************************************************************************************************
fatal: [localhost]: FAILED! => {"changed": false, "failed": true, "msg": "Running etcd as an embedded service is no longer supported. If this is a new install please define an 'etcd' group with either one, three or five hosts. These hosts may be the same hosts as your masters. If this is an upgrade please see https://docs.openshift.com/container-platform/latest/install_config/upgrading/migrating_embedded_etcd.html for documentation on how to migrate from embedded to external etcd.\n"}
	to retry, use: --limit @/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_7/upgrade.retry


But when visiting the URL "https://docs.openshift.com/container-platform/latest/install_config/upgrading/migrating_embedded_etcd.html", it shows

Not found
Sorry, but the page you were trying to view does not exist


The correct address should be "https://docs.openshift.com/container-platform/3.7/upgrading/migrating_embedded_etcd.html"



Version-Release number of the following components:
openshift-ansible-playbooks-3.7.46-1.git.0.37f607e.el7.noarch


How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Russell Teague 2018-11-20 13:52:56 UTC

*** This bug has been marked as a duplicate of bug 1596448 ***


Note You need to log in before you can comment on or make changes to this bug.