Bug 1575858 - quota crawler fails w/ TLS enabled
Summary: quota crawler fails w/ TLS enabled
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1557551
TreeView+ depends on / blocked
 
Reported: 2018-05-08 06:18 UTC by Sanoj Unnikrishnan
Modified: 2018-10-23 15:07 UTC (History)
7 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1557551
Environment:
Last Closed: 2018-10-23 15:07:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2018-05-08 06:36:37 UTC
REVIEW: https://review.gluster.org/19978 (Quota: Turn on ssl for crawler clients if needed) posted (#1) for review on master by sanoj-unnikrishnan

Comment 2 Worker Ant 2018-05-09 07:04:46 UTC
COMMIT: https://review.gluster.org/19978 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- Quota: Turn on ssl for crawler clients if needed

Problem: Quota uses per brick client generated by
glusterd_generate_client_per_brick_volfile to crawl the
individual bricks. These clients were not being configured
with ssl if volume has client.ssl turned on.

Solution: turn on client.ssl if the volume has client.ssl
option set to on.

Change-Id: Id3a13d5110c4376d734480c42da1ce6844cc8240
fixes: bz#1575858
Signed-off-by: Sanoj Unnikrishnan <sunnikri@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:07:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.