Bug 1575859 - [Ceph-ansible] - nfs-ganesha packages are not getting upgraded through rolling update from 3.0Z2 to Z3
Summary: [Ceph-ansible] - nfs-ganesha packages are not getting upgraded through rollin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: z3
: 3.0
Assignee: Christina Meno
QA Contact: ceph-qe-bugs
Aron Gunn
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 06:23 UTC by Parikshith
Modified: 2018-06-12 03:55 UTC (History)
12 users (show)

Fixed In Version: RHEL: ceph-ansible-3.0.33-1.el7cp Ubuntu: ceph-ansible_3.0.33-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 18:20:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
rolling update log_vv (209.97 KB, text/plain)
2018-05-08 06:23 UTC, Parikshith
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 2570 0 None None None 2018-05-09 20:25:10 UTC
Red Hat Product Errata RHBA-2018:1563 0 None None None 2018-05-15 18:20:35 UTC

Description Parikshith 2018-05-08 06:23:31 UTC
Created attachment 1432995 [details]
rolling update log_vv

Description of problem:
nfs-ganesha packages are not getting upgraded through rolling update from 3.0Z2 to Z3

Version-Release number of selected component (if applicable):
rpm -qa | grep ansible
ansible-2.4.2.0-2.el7.noarch
ceph-ansible-3.0.32-1.el7cp.noarch


How reproducible:
always

Steps to Reproduce:
1. Configure Z2 cluster with NFS.
2. Upgrade to Z3 by running rolling update.


Actual results:
NFS packages are not upgraded.

TASK [ceph-nfs : install redhat nfs-ganesha-rgw and ceph-radosgw packages] **********
task path: /usr/share/ceph-ansible/roles/ceph-nfs/tasks/pre_requisite_non_container.yml:82
ok: [magna023] => (item=nfs-ganesha-rgw) => {"changed": false, "item": "nfs-ganesha-rgw", "msg": "", "rc": 0, "results": ["nfs-ganesha-rgw-2.5.5-3.el7cp.x86_64 providing nfs-ganesha-rgw is already installed"]}
ok: [magna023] => (item=ceph-radosgw) => {"changed": false, "item": "ceph-radosgw", "msg": "", "rc": 0, "results": ["2:ceph-radosgw-12.2.4-10.el7cp.x86_64 providing ceph-radosgw is already installed"]}

NFS Packages in Z2:
-------------------
nfs-ganesha-2.5.5-3.el7cp.x86_64
nfs-ganesha-debuginfo-2.5.5-3.el7cp.x86_64
nfs-ganesha-rgw-2.5.5-3.el7cp.x86_64

NFS packages in Z3 repo( that is to be upgraded to):
---------------------------------------------------
nfs-ganesha-2.5.5-5.el7cp.x86_64.rpm                                           
nfs-ganesha-rgw-2.5.5-5.el7cp.x86_64.rpm    

Expected results:
NFS packages should be upgraded

Additional info:
I can manually upgrade on nfs node:
sudo yum update nfs-ganesha
Loaded plugins: fastestmirror, langpacks, priorities, product-id, search-disabled-repos, subscription-manager
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package nfs-ganesha.x86_64 0:2.5.5-3.el7cp will be updated
--> Processing Dependency: nfs-ganesha = 2.5.5-3.el7cp for package: nfs-ganesha-rgw-2.5.5-3.el7cp.x86_64
---> Package nfs-ganesha.x86_64 0:2.5.5-5.el7cp will be an update
--> Running transaction check
---> Package nfs-ganesha-rgw.x86_64 0:2.5.5-3.el7cp will be updated
---> Package nfs-ganesha-rgw.x86_64 0:2.5.5-5.el7cp will be an update
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                      Arch                Version                     Repository                                                                                                                      Size
===================================================================================================================================================================================================================
Updating:
 nfs-ganesha                  x86_64              2.5.5-5.el7cp               download-node-02.eng.bos.redhat.com_composes_auto_ceph-3.0-rhel-7_latest-RHCEPH-3-RHEL-7_compose_Tools_x86_64_os_              649 k
Updating for dependencies:
 nfs-ganesha-rgw              x86_64              2.5.5-5.el7cp               download-node-02.eng.bos.redhat.com_composes_auto_ceph-3.0-rhel-7_latest-RHCEPH-3-RHEL-7_compose_Tools_x86_64_os_               34 k

Transaction Summary
===================================================================================================================================================================================================================
Upgrade  1 Package (+1 Dependent package)

Workaround: NFS node can be upgraded manually.
1. Stop nfs-ganesha service
2. yum update nfs-ganesh
3. Start the nfs-ganesha service

I have attached the rolling update log.

Comment 4 Ken Dreyer (Red Hat) 2018-05-10 21:46:57 UTC
v3.0.33 upstream has the fix.

Comment 8 subhash 2018-05-11 17:01:47 UTC
nfs-ganesha packages are now getting upgraded through rolling update from 3.0Z2 to Z3 ,moving to verified state.

Version-Release number of selected component (if applicable):
rpm -qa | grep ansible
ansible-2.4.2.0-2.el7.noarch
ceph-ansible-3.0.33-1.el7cp


NFS Packages in Z2:
-------------------
nfs-ganesha-2.5.5-3.el7cp.x86_64
nfs-ganesha-rgw-2.5.5-3.el7cp.x86_64

NFS packages in Z3 repo( after upgrade):
---------------------------------------------------
nfs-ganesha-2.5.5-5.el7cp.x86_64.rpm                                           
nfs-ganesha-rgw-2.5.5-5.el7cp.x86_64.rpm

Comment 11 errata-xmlrpc 2018-05-15 18:20:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1563


Note You need to log in before you can comment on or make changes to this bug.