Bug 1575867 - [CNS][3.7] cns pods should in same namespace as docker-registry during cns as docker registry back end storage
Summary: [CNS][3.7] cns pods should in same namespace as docker-registry during cns as...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.7.z
Assignee: Jose A. Rivera
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On: 1545042
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 06:36 UTC by Wenkai Shi
Modified: 2018-11-19 21:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1545042
Environment:
Last Closed: 2018-11-19 21:46:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wenkai Shi 2018-05-08 06:36:27 UTC
Same issue in openshift-ansible-3.7.46-1.git.0.37f607e.el7.

# openshift version
openshift v3.7.46
kubernetes v1.7.6+a08f5eeb62
etcd 3.2.8
# oc get po
NAME                       READY     STATUS    RESTARTS   AGE
docker-registry-1-tvjdt    1/1       Running   0          25m
registry-console-1-rnbfn   1/1       Running   0          25m
router-1-kc9nv             1/1       Running   0          26m
# oc get po -n glusterfs 
NAME                                           READY     STATUS    RESTARTS   AGE
glusterblock-registry-provisioner-dc-1-8vg8b   1/1       Running   0          28m
glusterfs-registry-45pgv                       1/1       Running   0          31m
glusterfs-registry-pxkbv                       1/1       Running   0          31m
glusterfs-registry-rpjdx                       1/1       Running   0          31m
heketi-registry-1-zmg5s                        1/1       Running   0          29m

+++ This bug was initially created as a clone of Bug #1545042 +++

Description of problem:
During deploy cns as docker registry back end storage, cns pods should be in same namespace(default) as docker-registry.

Version-Release number of the following components:
openshift-ansible-3.6.173.0.103-1.git.0.dcf417c.el7

How reproducible:
100%

Steps to Reproduce:
1. Deploy CNS as docker registry back end storage
2.
3.

Actual results:
# oc get po -n default
NAME                       READY     STATUS    RESTARTS   AGE
docker-registry-1-45l82    1/1       Running   0          2h
registry-console-1-m2fr7   1/1       Running   0          2h
router-1-njvrn             1/1       Running   0          2h
# oc get po -n glusterfs
NAME                                           READY     STATUS    RESTARTS   AGE
glusterblock-registry-provisioner-dc-1-b6326   1/1       Running   0          2h
glusterfs-registry-r0wr3                       1/1       Running   0          2h
glusterfs-registry-s0h60                       1/1       Running   0          2h
glusterfs-registry-vc16c                       1/1       Running   0          2h
heketi-registry-1-0k1vb                        1/1       Running   0          2h

Expected results:
CNS related pods should in default namespace in this case.

Additional info:

--- Additional comment from Wenkai Shi on 2018-02-21 22:14:53 EST ---

Change target release to 3.6.z since 3.9 doesn't has such issue.

Comment 1 Wenkai Shi 2018-06-27 03:30:55 UTC
Check with version openshift-ansible-3.7.55-1.git.14.cfcf401.el7, this issue still appear. 

# oc get po
NAME                       READY     STATUS    RESTARTS   AGE
docker-registry-1-44zmc    1/1       Running   0          7m
registry-console-1-kjq5h   1/1       Running   0          5m
router-1-5pxvm             1/1       Running   0          8m

# oc get po -n glusterfs 
NAME                                           READY     STATUS    RESTARTS   AGE
glusterblock-registry-provisioner-dc-1-6dcd7   1/1       Running   0          10m
glusterfs-registry-cb5f9                       1/1       Running   0          16m
glusterfs-registry-gv8qf                       1/1       Running   0          16m
glusterfs-registry-wkps6                       1/1       Running   0          16m
heketi-registry-1-zxxmz                        1/1       Running   0          11m

# oc version
oc v3.7.55
kubernetes v1.7.6+a08f5eeb62
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://qe-weshi-cns37-master-etcd-1:8443
openshift v3.7.55
kubernetes v1.7.6+a08f5eeb62

Comment 2 Yaniv Kaul 2018-08-08 13:42:21 UTC
Can you take a look?

Comment 3 Jose A. Rivera 2018-08-08 14:01:15 UTC
Not any time soon. I also don't remember this issue still existing in 3.10, so it may be inappropriate to move it to 3.10.z.

Wenkai, can you see if this is still an issue in 3.10?

Comment 4 Wenkai Shi 2018-08-21 03:33:38 UTC
Checked with version openshift-ansible-3.10.28-1.git.0.9242c73None.noarch, 3.10 doesn't have such issue.

# oc get po -n default
NAME                                           READY     STATUS    RESTARTS   AGE
docker-registry-1-6hr9h                        1/1       Running   0          46m
glusterblock-registry-provisioner-dc-1-c9m96   1/1       Running   0          47m
glusterfs-registry-5mpmn                       1/1       Running   0          52m
glusterfs-registry-jnw2x                       1/1       Running   0          52m
glusterfs-registry-twctf                       1/1       Running   0          52m
heketi-registry-1-xllxg                        1/1       Running   0          49m
registry-console-1-ftsg9                       1/1       Running   0          46m
router-1-sgjd9                                 1/1       Running   0          46m
# oc get po -n glusterfs 
No resources found.

Comment 5 Russell Teague 2018-11-19 21:46:02 UTC
There appear to be no active cases related to this bug. As such we're closing this bug in order to focus on bugs that are still tied to active customer cases. Please re-open this bug if you feel it was closed in error or a new active case is attached.


Note You need to log in before you can comment on or make changes to this bug.