Bug 1575897 - Fail to upgrade containerized ocp deployed on rhel due to atomic binary unavailable
Summary: Fail to upgrade containerized ocp deployed on rhel due to atomic binary unava...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Michael Gugino
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 08:29 UTC by liujia
Modified: 2018-07-30 19:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:14:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:14:59 UTC

Description liujia 2018-05-08 08:29:55 UTC
Description of problem:
Upgrade against containerzied ocp on rhel failed at task[openshift_node : Pre-pull node system container image] due to atomic binary was not unavailable on the hosts.

TASK [openshift_node : Pre-pull node system container image] ****************************************************************************************************************
fatal: [qe-jliu-c39a-master-etcd-1]: FAILED! => {"msg": "The conditional check ''Pulling layer' in pull_result.stdout' failed. The error was: error while evaluating conditional ('Pulling layer' in pull_result.stdout): Unable to look up a name or access an attribute in template string ({% if 'Pulling layer' in pull_result.stdout %} True {% else %} False {% endif %}).\nMake sure your variable name does not contain invalid characters like '-': argument of type 'StrictUndefined' is not iterable"}

# atomic --help
-bash: atomic: command not found

- name: Pre-pull node system container image
  command: >
    atomic pull --storage=ostree {{ system_osn_image }}
  register: pull_result
  retries: 3
  delay: 5
  until: pull_result.rc == 0
  changed_when: "'Pulling layer' in pull_result.stdout"


Version-Release number of the following components:
openshift-ansible-3.10.0-0.36.0.git.0.521f0ef.el7.noarch


How reproducible:
always

Steps to Reproduce:
1. Run upgrade against docker containerzied ocp on rhel(setting openshift_disable_check=docker_image_availability to workaround another issue)
2. 
3.

Actual results:
Upgrade failed.

Expected results:
Upgrade succeed.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Michael Gugino 2018-05-08 20:50:37 UTC
PR Created: https://github.com/openshift/openshift-ansible/pull/8301

Comment 2 liujia 2018-05-09 08:12:29 UTC
Block container upgrade test.

Comment 3 liujia 2018-05-15 09:03:24 UTC
Verified on openshift-ansible-3.10.0-0.41.0.git.0.88119e4.el7.noarch

Comment 5 errata-xmlrpc 2018-07-30 19:14:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.