Bug 1575901 - Fluentd daemonset nodeSelector from deployment (facts) is replaced by inventory deployment nodeSelector
Summary: Fluentd daemonset nodeSelector from deployment (facts) is replaced by invento...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.10.0
Assignee: ewolinet
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 08:48 UTC by Junqi Zhao
Modified: 2018-07-30 19:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:14:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:17 UTC

Description Junqi Zhao 2018-05-08 08:48:32 UTC
Description of problem:
This defect is split from https://bugzilla.redhat.com/show_bug.cgi?id=1561196#c15

Deploy logging firstly and change fluentd nodeSelector to non-default value, logging-infra-test-fluentd=true

# oc get ds
NAME              DESIRED   CURRENT   READY     UP-TO-DATE   AVAILABLE   NODE SELECTOR                     AGE
logging-fluentd   2         2         2         2            2           logging-infra-test-fluentd=true   10m

Update logging with the same inventory, fluentd nodeSelector would always use the default nodeSelector logging-infra-fluentd=true, not get the existing nodeSelector from environment

# oc get ds
NAME              DESIRED   CURRENT   READY     UP-TO-DATE   AVAILABLE   NODE SELECTOR                AGE
logging-fluentd   2         2         2         2            2           logging-infra-fluentd=true   15m

Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift-ansible
openshift-ansible-roles-3.9.27-1.git.0.52e35b5.el7.noarch
openshift-ansible-docs-3.9.27-1.git.0.52e35b5.el7.noarch
openshift-ansible-playbooks-3.9.27-1.git.0.52e35b5.el7.noarch
openshift-ansible-3.9.27-1.git.0.52e35b5.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1. See the description part
2.
3.

Actual results:
Always use 

Expected results:
Should use existing fluentd nodeSelector

Additional info:

Comment 5 Junqi Zhao 2018-05-16 05:21:07 UTC
Tested with openshift-ansible-3.10.0-0.47.0.git.0.c018c8f.el7.noarch
existing nodeselectors for fluentd could be used when update logging

Comment 7 errata-xmlrpc 2018-07-30 19:14:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.