Bug 1575903 - Default value for openshift_logging_elasticsearch_memory_limit is too small
Summary: Default value for openshift_logging_elasticsearch_memory_limit is too small
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.10.0
Assignee: Jeff Cantrill
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 08:54 UTC by Junqi Zhao
Modified: 2018-07-30 19:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:14:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:17 UTC
Github openshift openshift-ansible pull 8761 None None None 2018-06-14 14:00:48 UTC
Github openshift openshift-ansible pull 8931 None None None 2018-06-22 18:11:04 UTC

Description Junqi Zhao 2018-05-08 08:54:57 UTC
Description of problem:
Default value for openshift_logging_elasticsearch_memory_limit is too small, it is only 1Gi, original value was 8Gi, it's better to change back

Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift-ansible
openshift-ansible-roles-3.9.27-1.git.0.52e35b5.el7.noarch
openshift-ansible-docs-3.9.27-1.git.0.52e35b5.el7.noarch
openshift-ansible-playbooks-3.9.27-1.git.0.52e35b5.el7.noarch
openshift-ansible-3.9.27-1.git.0.52e35b5.el7.noarch

#  grep -r "openshift_logging_elasticsearch_memory_limit"
roles/openshift_logging/tasks/install_logging.yaml:    openshift_logging_elasticsearch_memory_limit: "{{ openshift_logging_es_ops_memory_limit }}"
roles/openshift_logging/tasks/install_logging.yaml:    openshift_logging_elasticsearch_memory_limit: "{{ openshift_logging_es_ops_memory_limit }}"
roles/openshift_logging/tasks/set_defaults_from_current.yml:          __openshift_logging_elasticsearch_memory_limit: elasticsearch.resources.limits.memory
roles/openshift_logging/tasks/set_defaults_from_current.yml:      openshift_logging_elasticsearch_memory_limit: openshift_logging_elasticsearch_memory_limit | __openshift_logging_elasticsearch_memory_limit
roles/openshift_logging_elasticsearch/defaults/main.yml:openshift_logging_elasticsearch_memory_limit: "{{ openshift_logging_es_memory_limit | default('1Gi') }}"
roles/openshift_logging_elasticsearch/tasks/main.yaml:    es_memory_limit: "{{ openshift_logging_elasticsearch_memory_limit }}"
roles/openshift_logging_elasticsearch/templates/2.x/es.j2:              value: "{{openshift_logging_elasticsearch_memory_limit}}"
roles/openshift_logging_elasticsearch/templates/5.x/es.j2:              value: "{{openshift_logging_elasticsearch_memory_limit}}"

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
Default value for openshift_logging_elasticsearch_memory_limit is 1Gi

Expected results:
Default value for openshift_logging_elasticsearch_memory_limit should be 8Gi

Additional info:

Comment 3 openshift-github-bot 2018-06-21 23:31:03 UTC
Commits pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/04fb9b4ccab2337f22365fe38cfeda7daf4ec624
bug 1575903. Default ES memory to 8G

https://github.com/openshift/openshift-ansible/commit/3ef81eee7c59fb3aeb9b1b1b78ae0d45ef444236
Merge pull request #8761 from jcantrill/1575903_es_mem

bug 1575903. Default ES memory to 16G

Comment 4 Jeff Cantrill 2018-06-22 18:11:05 UTC
3.10 PR https://github.com/openshift/openshift-ansible/pull/8931

Comment 6 Junqi Zhao 2018-07-09 01:03:20 UTC
Default value for openshift_logging_elasticsearch_memory_limit, openshift_logging_es_memory_limit and  openshift_logging_es_ops_memory_limit is 16Gi now

# rpm -qa | grep openshift-ansible
openshift-ansible-docs-3.10.14-1.git.273.a64b86b.el7.noarch
openshift-ansible-playbooks-3.10.14-1.git.273.a64b86b.el7.noarch
openshift-ansible-3.10.14-1.git.273.a64b86b.el7.noarch
openshift-ansible-roles-3.10.14-1.git.273.a64b86b.el7.noarch

Comment 8 errata-xmlrpc 2018-07-30 19:14:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.