This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 157593 - Display corrupted when using Cirrus Logic GD5480 video
Display corrupted when using Cirrus Logic GD5480 video
Status: CLOSED DUPLICATE of bug 161242
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-12 19:46 EDT by Mike Pepe
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-11 19:52:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg log output (41.76 KB, text/plain)
2005-05-24 15:51 EDT, Mike Pepe
no flags Details
x config file (2.65 KB, text/plain)
2005-05-24 15:53 EDT, Mike Pepe
no flags Details
corrupted screen (609.24 KB, image/jpeg)
2005-06-16 05:31 EDT, Marco
no flags Details
my xorg.conf (2.77 KB, text/plain)
2005-06-16 05:32 EDT, Marco
no flags Details
my xorg log file (53.22 KB, text/plain)
2005-06-16 05:34 EDT, Marco
no flags Details

  None (edit)
Description Mike Pepe 2005-05-12 19:46:30 EDT
Description of problem:

Cirrus Logic GD5480 video output corrupted during graphical install and gdm
greeter on Intel SC450NX integrated PCI video.

Version-Release number of selected component (if applicable):


How reproducible:

Everytime.

Steps to Reproduce:
Choose graphical install. When X server starts, display will be corrupted.
It does not cause a crash, the system will run and install but you will not be
able to see the video. 
Text mode installation and running system in runlevel 3 works fine.
  
Actual results:

Corrupt display with vertcial multicolored bars.

Expected results:

Fedora Core installer screen and/or graphical login screen.

Additional info:

[root@test ~]# lspci -vt
-+-[0000:01]-+-01.0  3Com Corporation 3c905B 100BaseTX [Cyclone]
 |           +-03.0  LSI Logic / Symbios Logic 53C896/897
 |           +-03.1  LSI Logic / Symbios Logic 53C896/897
 |           +-04.0-[0000:02]--
 |           \-04.1  Mylex Corporation DAC960PG
 \-[0000:00]-+-08.0  LSI Logic / Symbios Logic 53c810
             +-0a.0  Cirrus Logic GD 5480
             +-0b.0  Intel Corporation 683053 Programmable Interrupt Device
             +-0c.0  Intel Corporation 82371AB/EB/MB PIIX4 ISA
             +-0c.1  Intel Corporation 82371AB/EB/MB PIIX4 IDE
             +-0c.2  Intel Corporation 82371AB/EB/MB PIIX4 USB
             +-0c.3  Intel Corporation 82371AB/EB/MB PIIX4 ACPI
             +-10.0  Intel Corporation 450NX - 82451NX Memory & I/O Controller
             +-12.0  Intel Corporation 450NX - 82454NX/84460GX PCI Expander Bridge
             \-13.0  Intel Corporation 450NX - 82454NX/84460GX PCI Expander Bridge
Comment 1 Mike A. Harris 2005-05-24 12:22:16 EDT
Does the corruption occur if you boot into runlevel 3 and run "startx"
also?

Attach your X server log file and config file to the report.

Thanks in advance.



Setting status to "NEEDINFO"
Comment 2 Mike Pepe 2005-05-24 15:51:32 EDT
Created attachment 114797 [details]
xorg log output
Comment 3 Mike Pepe 2005-05-24 15:53:18 EDT
Created attachment 114798 [details]
x config file
Comment 4 Mike Pepe 2005-05-24 15:55:08 EDT
Yes, booting into level 3 and then starting X results in the same display
corruption. Killing the x server returns you to a text mode with similarly
corrupted output. A reboot is required to return the display to something readable.
Comment 6 Paul Coleman 2005-05-31 08:41:44 EDT
I have a Via C3 system with the trident cyberblade/i1 graphics chipset. When X
starts (graphical install or system boot) I get a white screen. Dropping to a
terminal I get a corrupted display with vertical bars. If I blindly log in I get
text mode screen with a one character wide blue border. I like to see the
priority get bumped.
Comment 7 John 2005-06-14 00:41:57 EDT
I had the same issue when I tried to upgrade to FC4 T3. I ended up not 
upgrading and went back to FC3 where I have no problems with the video.

I tried to upgrade to FC4 and the same vertical bars in graphical.

I found this old Bugzilla by searching around Google. Will this resolve the 
issue?

https://bugzilla.redhat.com/bugzill...ug.cgi?id=24177
Comment 8 Marco 2005-06-16 05:30:07 EDT
I've the same problem with Fedora Core 4 final x86_64 version and xorg 6.8.2-37
The problem occur only with KDE and not with gnome!

my conf:
FC4-x86_64 final
Athlon64 3000+
1 GB of ram
GeForce6600 GT
nv module (no nvidia module installed yet)

Attach screenshot and my xorg.conf, are my issue related?
Comment 9 Marco 2005-06-16 05:31:47 EDT
Created attachment 115529 [details]
corrupted screen
Comment 10 Marco 2005-06-16 05:32:31 EDT
Created attachment 115530 [details]
my xorg.conf
Comment 11 Marco 2005-06-16 05:34:38 EDT
Created attachment 115531 [details]
my xorg log file
Comment 12 Mitch Horwood 2005-06-17 01:18:09 EDT
Marco,

Your problem appears to be different, albiet of similiar nature.  I'm running a
few HP Netserver LPr's with the Cirrus Logic GD5480 GFX, and believe me, your
display is much, much more readable than mine!

This is really frustrating for my poor fleet of netservers - Fedora Core 4
brought back support for the NetRaid card (Megaraid) and took away the gfx!

Good luck with this guys, any assistance with this problem would be greatly
appreciated.
Comment 13 James Couball 2005-07-09 22:58:40 EDT
I have an Intel G440LX with a Cirrus Logic GD5480.

I experienced the same problem as original poster: boot to X and display is
corrupted.

The solution in bug 161242 (using the libvgahw.a compiled for fc3) made my
display work.  I believe this bug is a duplicate of bug 161242.  The people
working on that bug believe it is a gcc bug.
Comment 14 Mike A. Harris 2005-07-11 19:52:01 EDT
Thanks for the update James.



*** This bug has been marked as a duplicate of 161242 ***

Note You need to log in before you can comment on or make changes to this bug.