Bug 1575932 - Activation keys show multiple copies of repositories after upgrade to 6.3
Summary: Activation keys show multiple copies of repositories after upgrade to 6.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Activation Keys
Version: 6.3.1
Hardware: All
OS: All
high
high
Target Milestone: Unspecified
Assignee: Samir Jha
QA Contact: jcallaha
URL:
Whiteboard:
: 1599072 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 10:31 UTC by Anand Agrawal
Modified: 2019-08-12 14:36 UTC (History)
5 users (show)

Fixed In Version: tfm-rubygem-katello-3.4.5.87-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 15:23:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
verification screenshot (138.04 KB, image/png)
2018-10-22 19:35 UTC, jcallaha
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 20057 0 None None None 2018-05-17 19:43:48 UTC
Red Hat Knowledge Base (Solution) 3535321 0 None None None 2018-10-11 15:08:19 UTC
Red Hat Product Errata RHBA-2018:3411 0 None None None 2018-10-30 15:23:17 UTC

Description Anand Agrawal 2018-05-08 10:31:31 UTC
Description of problem:

Activation Keys screen shows the same repositories many times.

We noticed that there are 2 occurrences of each repository in the list. These activation keys happen to have 2 different subscriptions attached to them. Perhaps the fact that the subscriptions show up as 2 separate entities are related to why the repositories are listed multiple times?

When removing subscriptions from the activation key, we can confirm that with only one subscription attached, the repositories are only listed once. With two subscriptions they are listed twice and so on.

The same thing happens with a newly created activation key when I add subscriptions to it.



Version-Release number of selected component (if applicable):
6.3.1

How reproducible:
Always

Steps to reproduce:

1. Navigate to Content => Activation Keys
2. Click any activation key
3. Select the Repository Sets tab

Actual results:

Repositories are listed multiple times in the "Repository Sets" tab for each activation key

Expected results:

Repositories should be listed uniquely in the "Repository Sets" tab for each activation key

Additional info:

Comment 5 Samir Jha 2018-05-17 19:45:32 UTC
This bug should be resolved by changes in the associated upstream issue. Moving to post.

Comment 6 Brad Buckingham 2018-07-24 16:36:04 UTC
*** Bug 1599072 has been marked as a duplicate of this bug. ***

Comment 10 jcallaha 2018-10-22 19:34:59 UTC
Verified in satellite 6.3.5 Snap 1.

Followed reproducer steps. In the past, I've encountered this many times. However, with this build, I have no issues with the duplicates. See attached screenshot for verification.

Comment 11 jcallaha 2018-10-22 19:35:17 UTC
Created attachment 1496489 [details]
verification screenshot

Comment 13 errata-xmlrpc 2018-10-30 15:23:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3411


Note You need to log in before you can comment on or make changes to this bug.